PC Game Pass - Infinite loading screen on new game / continue

True, I was wondering that as well ?. :thinking:

Got it! Thanks for the info, much appreciated :pray: We’ll keep investigating and monitoring the situation and do our best to keep you updated on how this develops.

UPDATE: We have “flipped a switch” which should help with this issue, but it’s likely that there is a bit of a delay for the change to come into effect.


I edited my previous post to include some details and information about offline play;


thank you very much appreciated, i hope you guys fix it as soon as possible. :raised_hands: :v:

Hey @SR_knivspark
I see you are aware of the issues at hand, and appreciate your readiness.

I am also experiencing the same issues except I am on Windows 11.
I tried restarting Xbox App, and everything else the forums suggested, but to no success.

My specs are:
Processor Intel(R) Core™ i9-9900K CPU @ 3.60GHz 3.60 GHz
Installed RAM 32.0 GB
System type 64-bit operating system, x64-based processor
Graphics Card NVIDIA RTX 2080 TI

Any updates of any kind are greatly appreciated!

Offline doesn’t seem to work for me. Even after changing the setting to “ON” and unplugging my ethernet cable to my router still nothing but black screen.

Yes, this is the same for me as well.

1 Like

Yeah same here, now the game is letting me actually click on multiplayer, and I can sign into my Apex Connect account in the settings… But I still get an infinite loading screen when clicking new game or continue, and when I try to find a game in multiplayer the game crashes.

1 Like

Same here!!! Game will not load!!! Get a black screen with , stop sign logo in top right corner!!! And its not my pc!! All drivers up to date, uninstalled /reinstalled game!! Tried it on my gaming laptop also!!! Dose anyone have a clue how to fix???/

1 Like


I just got the game on my pc through xbox game pass.
The game goes into black screen loop with autosave icon blinking on the top right, right after the short introduction. The game crashes when I try to get into multiplayer lobby and as soon I hit the “Find Game”
button. The game didn’t even start so no players with me.

Hard Ware:
i7- 10700
Rtx 2060
Win 10 64bit


Moved to existing thread about the issue.


How long of a delay? Also since the forums doesn’t show a time stamp of when a post was edited, for things like this, could we get a possible manual timestamp added to these sort of things?

1 Like

Same issue here, click on Multiplayer and the game crashes to Desktop instantly. Click on New Game and it goes to a infinite black screen with loading icon and stays there. Has the issue been fixed on your end or are you guys still investigating?

i try several times it dont work lets wait for tomorrow

I also tried to get the game to work multiple times but I couldn’t. I’m using windows 10 and I also set the game to the lowest graphics but it didn’t change. It seems like its happening to a lot of other people so I’m glad its not just my computer. I’ll try to run the game again sometime tommorow probably.

ETA ??? This is crazy!!! Thanks for a very vague response!!!

Hey, I tried the game on xbox and I loved it so I installed it on PC to play with my partner online, but in pc I’m having an infinite loading screen if I create new character or click continue, also, the game crashes whenever I try to search for multiplayer games

1 Like

Yes !!! Did this game just release ?

You dont! lol, Crazy that they cant fix a game thats been out since 2018

Yeah. smh my head they had so many years to fix an issue that just appeared yesterday.

I expect .2 secnd hotfixes nect time, or else.