Achievements still broken

Hello all,

I just wanted to post to let you guys know that I have experienced issues with achievements not unlocking this past week. These include…

  • Gustafsloppet (Run 90km) - both my mate and I have supposedly ran 400km as detailed within the stats page have not unlocked this. We have both created new characters and re-ran 90km and still nothing.
  • It’s The Final Countdown (Complete all Main Missions) this achievement does not unlock for the client player but all other mission achievements do. I’m not sure whether this is programmed like this but it didn’t unlock for me but did for the host. Can this be fixed?

Fashionista and I Want to Be a Mighty Pirate seem to be very buggy as in actually finding the necessary items which was very rare in our case. Again, we were not sure if it was meant to be like this.

It would be greatly appreciated if you could take the time to look into these issues. As far as I am aware these are the only issues currently with achievements.


Thank you for taking the time to report this issue. Can you please confirm which platform you’re playing on (PC, PS4, XBOX)?

You said that the achievement “It’s The Final Countdown (Complete all Main Missions) this achievement does not unlock for the client player but all other mission achievements do.”… Does this mean that the host was able to complete this achievement?

Regarding “Fashionista and I Want to Be a Mighty Pirate seem to be very buggy as in actually finding the necessary items which was very rare in our case.” … Did you ultimately find those items or are you still looking for them?

1 Like


The issue is on Xbox. The running distance achievement is a strange one because other people have managed to unlock it in the past few days however, my coop partner and I have tried on 2 different characters and it refuses to pop.

That is correct, the host obtained the achievement after we completed the final main mission but I did not despite obtaining the achievement for completing the mission.

Neither of us have found 200 apparel and have played around 25 hours. I have not found an eye patch yet within that time but my coop partner did but the drop weight seems to be non-existent. With regards to both of these achievements, they may not be ‘buggy’ per say but finding any clothing seems to be quite rare and we are unsure whether it is supposed to be like this?

Unfortunately, I have had that awful crashing issue on Xbox meaning I can’t even get past the main menu log in currently.


Thank you very much for replying with this information. Could you please share screenshots of your full mission log (main missions & side missions), as well as a screenshot of your distance traveled?

The eye patch is a very rare item to be found. Are you hunting it in the same location as the other items?

1 Like


I would love to share this with you but I can’t get past the log in screen currently as I have that crashing issue as detailed within another thread. We are all awaiting a patch for this as you may be aware.

I have been across a lot of the map looking for any items of clothing including the eye patch and barely find anything in chests etc. If it can be considered to buff the rate of finding apparel and the eye patch that would be great.


Thank you for confirming. I’ll follow-up with you again when you’re able to get into the game.

Thank you for patiently waiting for the issues with XBOX to be resolved and for reporting this bug, as well. It really helps the whole community.

1 Like

No problem! :slight_smile:

I can confirm that the “Gustafsloppet” achievement is broken for me as well on PC, currently have 230 km traveled.

1 Like

Would you be up for providing us with a copy of your save file?

  1. Your save file can be found here: Documents\Avalanche Studios\GenerationZero\Saves
  2. Right-click the save folder (containing “savegame” and “savegame.bac”) > send to > compressed (zipped) folder
  3. Go to (No account required)
  4. Click the “…” button and select “get transfer link”
  5. Add/attach the .zip archive with the save file(s)
  6. Upload and copy the link
  7. Send me a DM here on the forum and include the link from wetransfer
1 Like

I’m playing on the xbox one x and gustafsloppet has not unlocked for me also
I’m at 1521 km
I have all other achievements bar the collectables unlocked perfectly
Any help would be appreciated as I’ve really enjoyed playing this game and would like to hit the 1000 gs


Good Evening I’m also playing on the xbox one x and gustafsloppet has not unlocked for me also
im at 6,541km
thank you


hello im also having this problem im playing ps4 i travel in crouch mode all the time to avoid detection i have 113.08 km on the distance traveled but no trophy popped up also on generation zeros dashboard where ut says continue select character and so on it mentions about freddy as a drop but no clothing dropped i wiped my playstation saves and deleted all characters hoping it would fix bug but it didnt i have killed 282 machines so far after wiping save on 30th but no freddy parts are dropping maybe i have bad luck

PS4 first generation and PS4 pro.

Did all the missions yesterday’s, trophy’s did appear on the screen meanwhile I was playing ( the same on my sons PS4 pro ), after our play thru whe went in on trophy’s to check them all, whe had none, thought it perhaps rock som time for the network to sync, but the same today, tried to log on / log off, restart, log on thru the PS4 app but still the same.

Someone else with the same dilemma?
Any suggestions?

Best regards

Same here , notice it a few times.

Hi, I also have PS4 pro, I do see all Trophies.

Hey all, I’ve had a quick scower of the bug reports page and I can’t see anything to do with this.
Basically me and a friend set out and completed the FNIX rising campaign and got a few other things done, such as the 15 seekers with snipers, deafeted a rival etc.
Now it says we got the trophies in our activity feed but when we go to update the trophy list it says we don’t have any. Actually the completion rate is 0% among all players (crappy pic below for reference) meaning that we aren’t the only ones not getting them lol. Just a minor bug and thought I’d post it to make everyone aware!


1 Like

I just wanted to confirm what you are seeing - same here.

I have had several trophies dropping (for FNIX DLC, which I bought of course) but when checking later they are not listed as completed, and 0.0% total playerbase completion for every single one of the new trophies).

PSN trophy sync also seems weird - it takes longer than usual, making me think there is something missing on the PSN side, or the trophy IDs are off somehow (yes, wild guesses).

It would be interesting to hear if anyone DOES have the new trophies sync properly, and if so what region. I’m in EU btw.

Same here. (need 20 chars)

The same thing happened to many players when Alpine Unrest was available.
The trophies did not work.
The work around I discovered was…to begin a new save, and it worked, I got all of them.
Now…this method is only for Trophy hunters, after having them, you can delete the current save, and copy your old save back.
The plundra from the “old” save does not need to be deleted, just make sure you delete the right files, this way you begin with no skills, but with a great advantage in Weapons and ammo.
I do not know it this method will work again, if anyone tries it, please give feedback.

Well, almost like if the right person happened to see this thread - it’s now working suddenly, without any action whatsoever on my part. All trophies I had earned, but couldn’t see, are now there, and so is the global completion percentage.

Try it now, probably something was corrected on the PSN side :slight_smile:

1 Like