ADS scope problems

Platform: PC

Description: Probably a known bug by now but I have been experiencing persistent ADS bugs with scopes. Red dot scopes on ARs and also with rifle scopes. The problems is that about a third of the scope FOV is obscured by a black/dark overlay essentially blanketing the FOV while ADS.

Steps to reproduce: Add a scope to an AR or SMG and ADS.

Host or client: I was playing alone as I always do

Spec: Windows 7 home premium, 16 gig RAM, GTX 970

Tried to reproduce the issue (since i’m also on PC) and everything seems in order.

My results (click here to view)

5* Red Dot on 5* HP5.

5* 2-4x Handgun scope on 5* .44 Magnum, zoom: 2x.

5* 4-8x scope on 6* AG4, zoom: 4x.

5* 6-12x scope on 6* .50 cal, zoom: 6x.

5* 8-16x scope on 6* .50 cal, zoom: 8x.

Only scope missing is 1-4x rifle scope since i don’t use it.

More info about it would be in order, e.g screenshots/video (on PC and in Steam, default screenshot button is F12). Also, if you unequip the scope from weapon and re-equip, does the issue go away?

Though, most helpful would be detailed steps on how to reproduce it. Since i did try the current steps and didn’t get the bug result(s).

Hello again Aesyle.

I will try to get some screenshots for you. I will also try to un-equip/re-equip the scope ans see if that fixes the issue. Thanks again for getting back to me so fast.

I’ve seen this, once on my own computer (AMD gpu), and two times on my childrens computer (nVidia gpu). Both PCs are running Windows 10.
Seemed random, and never found the cause back then, sorry to say.

Based on description alone, i might have an idea what kind of bug it is. If it is what i suspect then i’ve also seen it but very rarely, about 3x times in total and with my binos. Unequip and re-equip has fixed it. But without screenshot/vid to actually see it, i can’t say for sure if it’s the same one.

1 Like

This is the ADS bug:

I did try to un-equip and re-equip the scope(s) but unfortunately I had no luck.

Yeah, that’s the issue i’ve also seen but extremely rarely. And that rarity is reason why i haven’t been able to reproduce it.

2nd thing to try:
Drop the weapon on the ground and pick it up along with all the parts. Assemble the weapon again and the issue should go away.

Also, how about detailed steps you did? So devs could reproduce the issue in-house and fix it.

This is with the red dot scope

I tried dropping the gun with the scope attached on the ground, then picking it back up. This was a good idea but it didn’t work for me unfortunately.

All I did was attach a scope to the gun. In this case it was a gold MP5 with a green 2 star scope. I had the same results regardless of scope/gun quality.

Do you have Dynamic Resolution enabled?

To be honest, I don’t know. None of the in-game graphical options have this option so in this respect I do not have DR turned on.

Sure they do. In your another topic about crashes vs in-game quality, i posted my graphical settings which also include Dynamic Resolution,
link: PC crashes in Feb 2020

Still thinking if you got your crashes sorted (for the most part) with different graphical settings.

Do you have vanilla GZ? GZ with Alpine Unrest? And/or are you using 3rd party mods as well (e.g from NexusMods)?

Also, do you have the issue as soon as your Continue your game, regardless the weapon/scope you’re using? Or does the bug appear in some point in game? If latter, what did you do prior of that bug appearing?

Another thing to try is validating game files via Steam.
Btw, February’s Update notes were just released and it’s rolling out. It may fix the issue,
patch notes:

1 Like

I indeed remember our discussion regarding my issue with crashes. I copied your settings to my game.

I cant find any graphical setting called Dynamic Resolution, I can only see a setting called Texture Resolution. Maybe there is some lingo confusion here. In any case I don’t think it matters that much. I can only hope that the scope bug issue gets patched one day. For now I will stick to the good old iron sights.

Here’s a screen:

I wonder, where it could be? :thinking:

Lol I can’t find it anywhere in my graphics menu honest! This is so weird, anyway like I said, I’ll stick to iron sights for now. Thanks for the screenshot!

It’s located in the “DISPLAY” menu.

Because it is located in Display menu :wink:

Yay… foto finish :rofl:


Ok cool so I wasn’t going mad… phew

I have encountered a bug that is a problem in my shot. It makes me very frustrated because this bug I have encountered it for a long time. I encountered it when steam let play this game for free for the first time. Please 9 Please fix this bug for me. I have tried it in many ways but it doesn’t work. Anyone who knows how to fix it please tell me. I have the following example.
20200627201001_1 20200627201015_1

This isn’t a bug, its an intended graphical feature of the game.