Aim Toggle OFF, holding mouse 2 down intermittently not working

Platform: PC

Description: Aim Toggle OFF, holding mouse 2 down intermittently not working. Sometimes even trying to get ADS on, takes 1-2 seconds.
Also ADS inputs seems to lag, small movement in ADS when it drops off, movement goes back to hip fire speeds, and aim jumps 1/3 or 1/4 screen to direction of movement. ADS returns. This is just like 100-250ms ADS off and on.
This is extremely bad, pretty much prevent using ADS in game.

Forget to mention, from launch game works random amount of time. After switching, fast traveling, etc. problem appears.

Steps To Reproduce: Set Aim Toggle OFF from game settings. Use any weapon, any scope or no scope.

Images / Videos: AimToggleOFF1 and AimToggleOFF2


Host or Client: Host

Players in your game: Solo

Specifications: i7, 16gb ram, GTX 980, Win 10 pro, Logitech: G502 Hero , G910, HOTAS x52 pro

Severity: Severe, game breaking.

Mouse, Keyboard and HOTAS works just fine in any other game. There has been times when games think HOTAS is gamepad, and gives inputs to games. Also HOTAS has its own mouse and drivers for it.
AimToggleOFF2 video, I have disconnected the HOTAS from my system, to check if this was the problem.

No YT account, and lazy to make one. Changed videos to links dropbox. Maybe that helps.

UPDATE 1: First, its seems that there is no programs to show keyboard & mice clicks on screen. (except OBS streaming pluging, not going to install & configure OBS for this)

Managed to manifest the bug with Logitech G HUB macro recording. While GZ is running mouse 2 does extreme fast up/down clicks. 10-100ms range.
Closed game, make same recording again. No problems.
(now back in game, and the problem is totally gone. Or its just as in description, its currently working)

It could be just me, but i can’t view neither of the two videos you posted. Tried FF and Chrome, nothing.

Here, i suggest that you upload the videos to Youtube and then link them here, rather than using Dropbox.

So, i tried to reproduce your issue (without me seeing your videos) and here are my findings;
I used 4x different ADS views:

  • 6-12x scope
  • 4-8x scope
  • Red Dot
  • Iron Sights

All looks normal to me. :thinking:

Note: I’m using Corsair Sabre RGB mouse + Corsair iCUE software and i have 0 issues. So, the issue could be with your hardware (or perhaps even with software).