Assignment 'Destroy FNIX base with grenade' not working

I had a base at Kallebyviken Control Point in the South Coast region. I used the G79 grenade launcher for the entire assault and did NOT get credit for it. Why?

My co-op buddy did the same assignment earlier with the same result but he did shoot a couple of runners with the assault rifle. The base itself was completely destroyed with grenades from the launcher.

Makes you wonder if the devs actually try these assignments out first before posting them?

Note: We have noticed that some assignments can not be completed with experimental ammo.

1 Like

Use hand grenades. The G79 will not work.


You and your buddy both need to use grenades. If anyone uses any other weapon it will not work

1 Like

Thank you for your comment…It had crossed our minds to use hand grenades but the assignment did not specify which type of grenades to use so logically you would think a grenade is a grenade when the ammo for the grenade launcher is called a grenade.

1 Like

Best to assume the assignments are designed around basics. So now, it seems no experimental ammo for example.

1 Like

I had to destroy two bases. First one did not count as successful and I only used handgrenades and medpack. Second try with handgrenades and medpacks was successful. So something was not working

It should say ‘hand grenades’, that would clear up any confusion. :+1:

1 Like

You going to love one of the assignments today then.

Another “weird” one ? :roll_eyes:

I really don’t like those as they’re not implying a “normal” gameplay imho…
At least not for me, ymmv though…

Oh and merry Xmas to all of you !!

1 Like

Ah yep. Stock up on 9mm.

Merry Christmas!

1 Like

I tried this last night using only hand grenades. My friend used other weapons. It did not register for me.

It won’t because someone else assaulting the base at the same time during a multiplayer game did not use grenades only.