Broken Quest in Satlhamn

I have bugged the quest in Salthamn, the one after you visit the Civll Servants’ houses.

So me and my partner were in Salthamn, with no idea what to do (we didn’t know about the nested mission info with names and map and stuff). So we activate the shelter, run around the town for a bit, and then see enemies on the sports field and think, “hey look, enemies. They usually point you in the right direction, so since don’t know what else to do lets take them out and search the area”

So we search the sports field. Note, we have NOT found the evacuation info in the Shelter, and we have NOT found the evacuation info inside of the Civil Servants’ Houses.

*** I find the audio recording in the car, and pick up the map off of the box (near the flares and spawn radio things) in the Sports Field in Salthamn *** Again, to be clear I have picked these quest items up too early.

So then we figure out that we missed something in the shelter, so we go back and find the info. We find the info in the houses. We go back to the Sports Field. The flares and spawners have respawned, but the quest items have not.

tl;dr Since the quest items don’t respawn, we can’t advance our quest.

We tried fast traveling to the farm, and the fast traveling back to Salthamn, and that did not work. The enemies and items came back, but not the quest stuff.

edit: I actually have the quest items listed in the log. Like I can see the map I picked up off the box, and see listen to the audio recording I picked up.

1 Like

Thank you for reporting!
Will the mission items update for you if you restart the game?

Restarting the game results in the items reappearing but the mission still does not progress even when re collected in the correct order.

1 Like

Few mates and I ran into the same problem but it worked for me after I solo’d it

1 Like

Got stuck here as well. Telling me to search the bunker for clues, but picking up the document doesn’t trigger anything. Restarting and picking up the document again doesn’t solve it.

What platform are you all playing on?

I’m playing on PC. The first time I got to the bunker I only went in 20m or so before I exited and went inside 1-2 of the houses outside. I then fast travelled back to the church to the NE and quit the game. The next time I played and walked back to the bunker (didn’t trigger the safe house the 1st visit) I picked up the document before starting the generator and it didn’t update anything.

@Cawl are you in a MP game? Can you solo it as XxXtdreaperXxX did?

Sorry, it was a false alarm in my case. I didn’t know there was a map in there I needed to find (someone mentioned it on the Steam forums), and picking it up seems to have updated the stage of the quest.


I have found two notes, one recording and two maps in Salthamn (solo), but the second map doesn’t appear in my log.
I even listen to the com-radio in the car.
The mission still says that i shall search for clues in salthamn.
Is this a bug or have i missed something?

It worked for me after restarting then looking at the map i found in the bunker, then going to the football field and listening to the com radio in the police car and picking up the objects from the table where the other map was again.

It’s a shame can’t reset missions but maybe just the host pickup things as that’s who the saved file is under