Bug on companion and disconnection in multiplayer

I play the ps4 and my companion disappears from inventory if I fall in battle against a rival I even back to battle location he’s not there I used items and sometimes disappears in the middle of battle. I even check the slot and it shows it’s greyed out like never bought dlc I literally had to exit the whole game just for it to fix it self. Multiplayer is useless cause it kicks anyone that joins in. They only stay connected 5 mins and then kicked through disconnection same on my end. My friend and I cannot even fight the lowest machine with out disconnection and it’s not internet we both use Comcast with the console plugged directly into the modem I hope fixed soon.

If need more information let me know

Do you play in the same house?

What’s your NAT type?

Also check your firewall settings in the router.

Not same house and it’s mat type 2

My brother figured this out. U cannot have the spotter modification on your companion whenever an eenmy gets spotted by your dog, the game will crash.

Simply remove the spotter mod and u issue solved.

But just counts for multiplayer, I guess, because on Singleplayer I don’t have any issues.

My problem is that after last update, the companion dissappeared in the mid game and when I deleted the game and started the fresh one, it still not there. It just gave me making friends mission and when i complete it I cant deply the companion. It’s not in the inventory or anywhere else. It happend after the update, before that it was working fine.
I am on pc and pc specs are =

  • 12th Gen Intel(R) Core™ i5-12400F 2.50 GHz
  • 32.0 GB (31.8 GB usable)
  • 64-bit operating system, x64-based processor
  • RTX 3060 Ti


this topic is about something else.
You should create an own bug report, maybe even send your safegame file to the support.

I guess you’re playing on steam? Or is it xbox gamepass on pc?

Did or do you use any mods?