Bugged main quest, escort truck mission- Truck will not move

Platform: PC

Description: me and my friend have been playing on my save. we’re at that point of the main quest where youre guarding the armored truck as it moves forward, like an escort mission. it doesnt get very far when it just stops moving, we kill all the robots that spawn, we close the game and open the game over and over, we have shot every single kind of bullet and explosive at that truck- it wont move. the quest text objectives doesnt change, kill the robots it says and doesnt change no matter how many we kill. ive even tried playing offline and alone, still the same. its such a bummer.

Is there any way to fix this bugged quest?

Steps To Reproduce: im not exactly sure what triggered this bug. we just followed the instructions of the main quest. we follow the truck down the road, we kill the robots coming in, and thats it really. it feels like a bug that just happened by chance, so reproducing it would be tricky.

Images / Videos: im updating the game rn, so i cant open it. it just looks like a stationary armored car in the middle of the road.
Edit ive installed the update! and there are no changes, its exactly the same, a stationary truck, mission says ive completed the objectives, killed all the robots nearby, and yet… nothing

Host or Client: i was hosting a multiplayer game for me and my friend. if it helps at all, i am from South East Asia, and my friend is from Europe.

Players in your game: only 2 players, me and my friend.

Specifications: my laptop is an ASUS TUF Gaming FX505DY