Building Blocks - can't complete - no control centre

Bugs about the Building Blocks mission have been submitted before, but the way the problem started for me may be slightly different.

I started playing after the original base building mission “Good News” had already been replaced by Building Blocks.

If I recall correctly, I came upon the base before unlocking the Building Blocks mission. I destroyed the base and claimed the control point.

Once the Building Blocks mission became available, I started it, proceeded to the Sjoglimten Control Point where I found my control point truck with 2 shield generators. Destroyed the shield generators but I’m now instructed to “Destroy the Command Centre”. Unfortunately, since I’d already destroyed the base this command centre no longer exists, only the resistance truck which replaced it.

I’ve tried levelling up the Farmlands region to threat 25 in the hopes that another FNIX base would spawn, but no luck - it seems completion of Building Blocks is required for any base assault/defence missions to begin.

This is very frustrating since running around killing Tanks has become a little dull - I’d really like to try the base assault and defence missions. I’ve attached a couple of screenshots showing the current situation. Hopefully this bug will be resolved soon otherwise my interest in the game will likely wane.

1 Like

I thought this one was fixed?
Today I continued my 2nd world an now came to the point of building blocks mission and it was just like explained.
2 shield Generators
0 command center
No chance to complete the mission.

I’ll stop at this point for today and take a look tomorrow again.

This bug is still a current thing. Please fix Devs I ran into this after picking up the game again. Jan 1st 2024