Can't do the High Value Target mission

Platform: Xbox 1 S

Description: Can’t fuel the generator or press the button. I tried fast traveling to different places and coming back but did not fix it. I tried testarting the game but nothing seemed to change. Sometimes the generator and everything else there except for the little tent thing would not spawn. I’ve played this mission solo on PC through steam and never encountered this issue.

Steps To Reproduce: Could not fix to reproduce.

Images / Videos:

Host or Client: Host

Players in your game: Solo at the time.

Specifications: Xbox 1 S (not really sure what else to put here)

Pictures I managed to snatch today of the generator and such not being there:

I have the same issue on Xbox One X

Played that mission yesterday evening. I’m on Steam and on PC. It runs without any problems for me. When i remeber it right you don’t have to refuel the generator. You must repair the switch cabinet what is on the left side, the side to the sea, and then you must go up and turn the Broadcast system on…

This should be different “for each player”. Either it’s that way or an other.

Can’t complete High Value Target

Platform: PS4

Description: went to rooftop, saw indicator over generator and began adding fuel. I didn’t have enough fuel (40 something) so I went and searched in the area for fuel. Returned with enough to top it off but there was no indicator.
I dropped a field radio, left and returned, still not there. My blue and white side mission indicator is there but I can’t initiate anything.
I restarted the game, came back the next day, returned on foot instead of field radio fast travel, nothing is bringing it back.
Just after the problem occurred, I went to fast travel to a random safehouse, but instead of fast traveling, the map focused on the Farudden Radar Mast which was flashing. I traveled to that location but saw no indicators on what to do when I got there.

Steps To Reproduce: I’m unable to initiate this side mission.

Images / Videos:

Host or Client: host

Players in your game: solo player

Specifications: N/A

Just guessing, but probably it’s actually intended that it just can be used once.
But in this case they must have thought that it’ll always be finished in the first attempt.

Well, that’s of course not possible if you don’t have enough fuel or repair kits.

For this case, in my eyes, the mission should be adjusted a bit, that you first have to get the fuel/repair kits and then become able to interact with the generator. (For example)

That should be happen. As i made that mission fortunately i had enough fuel and repair kits in my bagpack so i could finished it. One point is that you need more than one repair kit so it should be better that you get this items at the start of the mission.

1 Like

Hey! This bug is fixed in the next update, so no need to change the mission design^_^