Cant find all the missions. (if stuck or lazy)

This helped me with the missions just get a list of all the missions and tick them off
,if not on list add them to find.

if you need more then use this wonderful map

While GZ wiki is good, do note that the mission list is wrong.

Errors in the list:

  • it lists “Back on Track” as North Coast main mission while in fact, it’s Mountains region main mission.
  • it lists “Tilting at Windmills” as North Coast side mission while in fact it’s Forest region side mission.
  • it lists “The Spotter” as Farmlands side mission while in fact it’s North Coast region side mission.

Thanks for the note, I was stuck (because of the Hermelinen door glitch) so i did not pay much attention to the fine details.

What kind of door glitch? :thinking:

i got everything outside the bunker the note on the door the other key card i open the second entrance got though the tick infested hall and the last door to the generator is their, right in front of me but…IT… WOULD…NOT…LET…ME…IN?! I shot the :face_with_symbols_over_mouth: out of that dam door. it is the last thing that is stopping me from competing the game i have one mission left…only one…(which i am going to do tomorrow) (ps sorry if i overacted this costed me 50+ hours of gameplay to be for nothing, so sorry :sweat:)

Sry i was a nit-wit but i have got into the Hermelinen bunker and i am now on the FOA 53 mission.

What I am missing is the side mission or selected mission indicator.
“A soldier left his weapon cache in the woods. Go and find it.” Ok, where??

Some of the descriptions are really vague

if you track a mission it pops up on the map and if you get near it will give you instructions.

Yes it does - like “find a farm called BLA BLA in Farmlads”… OK?

A small marker will appear in your map ( depending on mission type ) which you can check using the legend feature in map.

That’s your way point for the current, tracked, active mission. I personally divide up the area into 4 and normally things progress naturally with expoloration.

Happy hunting.

Does not work, only for main missions. I have more than 300 hours in the game and finished the story with most side missions but this is an issue we’ve seen from very beginning. Side mission marker does not work on map and until you come into the area (<500m) there is no mission marker in the environment either.

When’s the last time you re-synced your profile in the 300 hours gameplay?

Re-synced? We started a new profile since our previous got corrupted, but it’s still not working.
I believe I saw this bug reported some time before. On the other side we used to remember where to go but this may be issue for new players.

Correct, there a regular posts for missing items, weapons, relay beacons, locations, markers, enemies that have all revolved around the same theme of issue of not appearing or tracking happening because of a cross gameplay error.

My only solution was to delete my local save, and re install the game - then re-sync my profile once i reloaded the game. It’s worked fine, but I’m on a MK1 save file and characters so I don’t know if my game file is different?

If it’s that annoying - you could always just use a YT guide - but generally natural exploration is the key here. I used to be focused on 1 mission only at a time, but it’s a big map - and a lot crossed over into different areas.

Am i correct if the mission you talk about is Prospect Tunnel? If so, when you read the mission start jorunal, it lists the exact co-ordinates of the cave.

It was just an example. Ă–stra Mark farm is another story. But as I said - we remember those locations, but it was PITA sometimes when we played for very first time.