Companion stuck in companions inventory

Aparently after picking up my destroyed companion he went into its own inventory instead of mine, now i cant get him out and cant make a new one either, since after picking up the new one it dissapeared completely.

Im playing on PC.

You just can have one companion. There is just one companion inventory. That’s the simple but sad reason.
How did you open the inventory of the companion to make the screenshot of a companion inside it?

Nevertheless, by trying to get more than one companions you broke it obviously.

(Did you maybe pick it up, put it into the plundra, started a new world to get a new companion and tried to put it into the companions inventory to transfer both into a single world?)

I opened the companion inventory in the companion station. As of what happened, i was raiding a fnix base, i won, my bot died, i didnt have any repairs on me so i decided to pick him up, but when i got to the companion station i noticed that my bot is in its own inventory. so i went to another world and done the quest all over again. And no i didnt interact with the plundra at all.

That is a little crazy.

I started carrying 6 or 7 repair kits and keep track of how many times I repaired it. I get to low I will make sure it is in some stage of repair, 50+ and pick it up. For my character to continue I only need health kits and the shots.
I also use my runner when attacking level 1 fnix bases. The spotter/rocket seems good against the runners and hunters at the base. But it also draws fire and takes it off me so I expect it to go down a few times. During battle I will only repair the runner if there is a break in the attack. The process of E then R takes a while in battle time.

Guesting you do not have any manually backed up save files to back up a little of your game play time?

You speak my language, i use him for the same stuff, taking fire while you blow the place up. And no i dont have any backup saves. It sucks cuz the only way i know how to fix this would be making a new character, but im not willing to grind all my levels back. Unless they fix it.

If it’s even possible. :man_shrugging:
Currently it looks like a very rare and personal bug, as I didn’t read other reports about that, but who knows.I don’t use social media.

Finally you should provide your safegame file to the devs.

Done. Now we have to wait and see. Thx for the link.

I wouldn’t do any starting over just yet. But in the mean time, you may want to consider “copy and paste” the game save files. They are very small and will help you recover from that time stamp of the copy.

I back up my files every so often just in case something happens with my game. I also do more than one back up folder and replace oldest with newest files so if something happens I can go backwards to more than one time/date.

Good luck on getting your runner back and welcome to the forum.


Thx. I feel like im gonna need the luck.

Well, I may have caught this bug sort of. Since I am very careful where I use my runner, I don’t know how it happened. But I started my game last night and no runner was in my inventory. Was Not inside itself and could not make a new one. I did not leave it out destroyed or anything, it vanished from my inventory in good health still. The only thing different from my last time playing was I crafted level 4 standard armor and equipped the runner with it, which didn’t take too long, and the armor was destroyed. That may have been the factor that caused my runner to vanish from inventory. Armor gone; the runner soon goes with it.

Lucky for me I do backups and just backed up the game a few days and all is well again.

Also, on PC/Steam. BTW, I have only been playing solo since the 09/05 update and still get a Steam disconnect notice while playing from time to time, very annoying.

hi-light the companion at take it out

Ahhh, if only it would be that easy, no you cant take it out like that, since hes not suppose to be there in the first place, cant put him in, cant pull him out.

Even not in another world?

Nope, doesnt work either. Btw i did get a reply from Avalanche that they are looking into in, so maybe in the next bugfix it will be fixed. Hopefully.


OMG, they actualy fixed it. Not sure when or how but they did. Or maybe buying a DLC did it.

1 Like