Crash to Desktop on Joining Co-op (PC)


PC Windows 10


Okay so here’s the deal every time I go to join my friend’s game via an invite the game will immediately crash to desktop without fail. I will hit the accept button in steam messages and then it will attempt to load and then I’m back to my desktop. Doesn’t matter if my character is loaded into my game world or if I join from the main menu it will crash every time.

Internet connection is good between all parties involved, the games are all up to date, all drivers are up to date on the computers, verified the files through Steam’s service. All parties involved have made sure to let the game through their firewalls to have access to the internet. I am completely lost on to what the possible issue is.

The messed up part is that I can connect to Randoms just fine via the matchmaker but any private game is an instant crash. I want to love the hell out of this game, I mean I already do but the bread and butter of it really lies in multiplayer. This has only started up in the last two days which is what sucks. Before that I was able to connect and play just fine.

The only thing I haven’t done is to uninstall and reinstall which shouldn’t be necessary. Its really frustrating since I’ve searched this topic and have seen that this issue isn’t actually a new one but one that people are still struggling with. If anyone has a solution beyond uninstall/reinstall I’d greatly appreciate it. I will update if I can find a work around or just go through with the wipe.

Steps To Reproduce:

Launch the game, receive the invite from my friends list via steam overlay. Hit accept. Game crashes to desktop while trying to load into game.

Images / Videos: None at this time

CPU: Ryzen 5 1500x
RAM: 16Gb 3000mhz
GPU: Zotac GTX 1060 6Gb
Storage: W/D 1Tb HDD

1 Like

Sorry to hear you’re having problems. Can we rule out you or your friend is running any mods?
I’d suggest a reinstall, though if you’ve verified the game files through Steam that should indeed not be necessary.

There are many reasons why one might suffer a disconnect or experience network issues but an outright crash to desktop as a result of joining via the overlay seems odd. :thinking:


Problems with any private game, or just this one?

No mods the game is vanilla for my friends and I

And its any private game I’ve tried to join. Two of my friends have similar issues.

Platform: PC Windows 10


Since earlier this week my roommate crashes to desktop when joining my coop game.

We’ve tried various permutations of joining: from desktop, from main menu, from a running game; from my desktop, from GeForce Now…

All result in a hard crash to desktop with the GenerationZero_F.exe message

We’re both newly installed, unmodded clients, joining a private game.

Gigabit cable connection, both clients on the same network using ethernet.

We’ve both ‘verified files’, and re-installed completely.
Graphics drivers up-to-date.

Just tried again tonight with the same result. It was fine for 12 hours of gameplay last week, but we haven’t connected successfully this week at all.

Steps To Reproduce:

Accept the invite for an already running game.

Any attempt to join the game I host results in the same crash. (all invite methods)

Intel i5, 32 gig ram, gtx 1080

I chimed in on another thread earlier in the week about the identical problem, but perhaps this will get more eyes.

thanks in advance for any suggestions.

Merged with the original topic, one thread about the same issue is enough. I’m going to poke someone about this though, so it can be looked into on monday.


1 Like


Thanks for the hustle.

Hi @Bushmaster501! :smile:

Thank you for the bug report!
Would it be possible to get your save file so that we can try and reproduce the bug? These are the steps to do that:

  1. Your save file can be found here: Documents\Avalanche Studios\GenerationZero\Saves
  2. Right-click the save folder (containing “savegame” and “savegame.bac”) > send to > compressed (zipped) folder
  3. Go to (No account or email required)
  4. Click the “…” button and select “get transfer link”
  5. Add/attach the .zip archive with the save file(s)
  6. Upload and copy the link
  7. Send me a DM here on the forum and include the link from wetransfer

And hi @taojoneses too! :wave:
Would it be possible to get your save as well? And perhaps your roommate’s save file too? (If that isn’t too big of an inconvenience.) Follow the steps above if you would like to do that :blush:

Thank you guys again for reporting, and sorry for the inconvenience!

Just the other day, my friend and I played this game co-op for about 2.5 hours with no problem. The next day, for some reason, we can’t seem to connect – regardless of whether he hosts, or I host. The game immediately crashes, every time. I have read that creating a new save file is a fix for this problem, but we’ve made a decent amount of progress in the time we’ve played and I don’t want that going to waste. Is there a fix for this?

My specs:
Ryzen 7 3700X
GTX 1070

I see more reports of this issue are trickling in. I’m merging this with the main thread about the issue, and hope to see this sorted soon.


We’ve found a solution! My friend and I were trying some things, and we found that replacing one player’s Save folder with the other player’s fixed the issue! We’re able to connect and play co-op by doing this, and I kept all my items and progress. I’m no programmer, but I wonder if this issue may be caused by uneven missing progression in co-op, specifically at some point near the three missions that become available after restoring power to the bunker. I know this may not be ideal for everyone, but if you were doing a co-op run from the start, this should work perfectly!

So, I’m 80 hours into a co-op game played online with my daughter - on W10 PC - and suddenly we’re not able to play: We boot up, begin the game, I invite her, she accepts, the game crashes at her end. We’ve both got good internet with a small ping, we’ve both validated the game files, restarted, rebooted, left it a week, and still no luck.

Anyone got any ideas?

Same issue topics merged.

Also, read above for a possible fix.


1 Like

No dice with the fix, I’m afraid. We tried replacing the save games…I took hers, she took mine, we tried each other’s, she tried to invite me as well…a crash to desktop every time.

Any other ideas?

I’ll DM the developer the save games today, as soon as I boot up the PC.

@taojoneses We’ve tested your save now! We were able to reproduce to crash in the live game. However, it did not crash at all on our latest build, so it might be that there is a fix coming with the next patch :crossed_fingers: Let me know otherwise!

@imaginaryZenith Nice find, happy that you were able to solve the issue! :smile:

Hi @mattinkent, thanks for reporting! Did you already DM the savefiles? I have not received a message, or did you DM someone else? I could ping them for you!

Glad you were able to replicate the issue.

Also good news that it fixes itself on the latest build, however the blog makes it look like months between patches :frowning:

Any ETA for the next patch?

1 Like

Just DM’d you a link now. Sorry for the wait.

Confident it’ll be fixed in the next update but… :frowning:

@taojoneses The release date will be communicated officially soon :smile:

@mattinkent Oh, no worries! If it’s the same issue as Taojoneses had then I’m confident in that too! Will look at the save when I get the time :blush: