Disappearing mines

I agree @bootie everything you put out there should be there when you come back. But if I went to the pub I would’nt remember what I put out in the first place…


Don’t worry about me. I’m not easily “offended” by choice of words and I don’t mind jokes. :slight_smile:

It’s just that humour is by far not so universal as you’d think (or like). Especially “on paper”. And “agitate” generally has a quite negative connotation. It easily sounds like: I’m going to annoy the crap out of them. Just saying :wink:

Anyways … It would be nice if you can catch it on video (a little tip just in case you’re unaware of the option: you can probably start a buffered recording. Quite handy :slight_smile: )

To bad you missed the stream (I missed all of them). But hopefully we get some clarity soon now that this has a bit more attention.

I completely agree with you. It was (and still is) one of the core principles of the game: don’t run into a fight Rambo-style and expect to survive. In stead, plan your actions, use the environment, set traps, etc.

I also tend to agree that the argument of saving resources is questionable for a couple of user placed objects. However, in defense of the devs: we don’t know the architecture of the game engine and the way it handles game objects. I’m actually extremely curious and virtually “dying” to have a look at the code. Not that that’s ever going to happen … obviously … sigh :upside_down_face:

Nevertheless, user placed objects should not disappear whatsoever (except when reaching a dedicated limit). Not even on fast traveling (which also happens when you re-spawn at a safehouse after you die).


I see you already added it to The List. Good stuff! :slight_smile:

I know my own quoted bug report is very long but did you watch the (entire) 55 second video there? It shows the problem very clearly (albeit with the Fuel Cells).

It is still reliably reproduce-able that way (at least, here on my system). They simply get deleted after walking away for barely 100 meters.

However, when there is more activity (or whatever the criteria are), these kind of place-able objects disappear “randomly”. Even from right under your nose like Flick said. There is no “visible” logic.

As a side step. I wonder if this mechanism could somehow be related to the “teleporting”/vanishing machines, the floating seeker jets or the ghost machine sounds.


In the tests for my own bug report I tried all the graphics settings from low to ultra and it did not appear to affect anything related to this problem. Not even the render distance of the placed Fuel Cells. (Even thrown grenades disappear before hitting the ground at the same distance regardless of settings).

Heyo, I haven’t watched the video but I know of the issue. It’s been popping up since release, though it’s been improved upon since then. It used to be, you couldn’t turn your head without mines, cells, gas cans etc disappearing. So the system could still use some adjustment.

1 Like

@Voodoo seems to be a coder so probably knows much more about what he’s talking about than I do (which is almost nothing computerate - although I do know what a stack is) and if he says that mines, bottles etc should be able to stay for the whole session, I trust he’s right. That is what we need to play the game is it was intended, rather than a bit more “adjustment”… :smiley: I wonder what’s making it go wrong? And how easy it is to fix? I’ll leave it with you now, having flagged it, unless I get into a conversation with one of the Team.

@Voodoo - where’s your video? (i.e. name of Bug Report). EDIT: Okay, found it - my word you do things carefully! I could at no point before the Plundra bear to lose so many looted items! Well done, but appalled that that was in August. Oh well.

The object cleanup algoritm can be a bit annoying. Mines, gas canisters and EMP-charges all suffer from it.

Sometime I have killed machines go up in smoke when the host fast travels to another location.

I don’t know how intelligent the clean up process is. I see several possible factors affecting how cleanup can be performed:

  • Range based cleanup - when host or player is far away cleanup is done faster.
  • Object count based - First in first out based probably?
  • Resource based - When the host starts to get resource constrained cleanup is performed faster?
  • Object type based - player based objects remain longer than killed machines?

And of course a few combinations of above.

I think the cleanup (garbage collection) should be adjusted so that player placed objects remain longer, especially simple objects like mines and gas canisters. (Back packs are a little bit more complicated as they contain objects with objects in them)


I wasn’t aware of that. I haven’t been around since the beginning and I couldn’t find anything related on the forum before I posted my report.


Noooooooooo, don’t leave me! :crazy_face::rofl:

Ex-coder actually. I had been typing my bud off for about 15 years but I was brute-forced to stop, unfortunately. :disappointed:
Never mind the details but let me just say that I really understand (and praise) the no-crunching-allowed-mentality at Avalanche Studios.

However, CodingVoodoo.exe shall only terminate when the whole system goes down. It’s like a rootkit, so, it keeps itching quite badly when it comes to these things.

Anyways … it’s not particularly relevant to this issue since objects should simply not arbitrarily disappear, imho. You don’t have to be a banker in order to be annoyed when your money gets snagged. :upside_down_face:

The bug report (with the video) was linked in my first reaction. Thanks for the compliment but it’s not nearly as “carefully” as I would like it to be. It’s long but actually also quite “sloppy”.

And I didn’t lose any stuff because I backed up my game save beforehand. Remember that cute little batch file? It can work the other way around too. :wink:


Machines can go up in smoke in single player too. I have exclusively played single player and I’ve “seen” more corpses vanish than I care to remember (and a couple of live ones too, by the way).

What I would expect is a dedicated array of user placed objects which is only “touched” if its own element count reaches its own dedicated maximum. As it “feels” now, all dynamically created objects are just dumped into the same big object pool from which they are picked “seemingly” randomly for removal.

But since we (or at least I) know absolutely nothing about the game engine, all is just pure speculation. It could be a really stupid idea (performance-wise) and it could be as far from reality as it possibly can be.

Like I said somewhere above. I wonder if this mechanism could somehow be related to the “teleporting”/vanishing machines, the floating seeker jets or the ghost machine sounds. It seems like a generic problem of (sub) objects being removed when they shouldn’t be, or not being removed when they should be.

So Avalanche, just post your source code already so we can put ourselves out off our curious misery! :stuck_out_tongue_winking_eye:

I shan’t leave you - I follow you blindly. Well, I think this has been noted (without confirmation from a DEV), and that we raise it politely when we get an opportunity - the broadcast for instance. Now I work Wednesdays, so I can’t go take part, but perhaps someone else can who’s reading this.

No one on the DEV team is grasping or stupid - we are all of us working to reach a place where it all works. It’s not the same here as trying to get News out of the Half Life guys as to what is going on next if anything - the DEVs are in contact all the time. (I’m talking to other readers here, rather than you, Voodoo). As I’ve said elsewhere, I’ve flagged it so as to be part of the solution, not part of the problem.

This side of the game was a big part of the promo, and therefore it was in their minds before it was in mine - we don’t need to sell them on the idea! What we can do is nudge a little and suggest solutions (not knowing the coding of course). Might be good to repost your video here as a nudge. But as soon as a DEV tells me they’ve heard us and got it in hand, I shall let go at once, and wait for it to reach the top of the list…

Today I witnessed my trap items (gas tanks, land mine, emp) vanish (actually being gone, from a distance) - and reappear once I was close enough again!

I’d guess they will not be rendered due to resources. Their re-appearance could be the problem.

EDIT: Of course I lost them at the end, as my game crashed not much later. :wink:
(I lost quite some stuff due to crashes, actually kind of annoyed atm.)

Either way, it should be fixable…




Funny that you mention Half-Life … a new game called Half-Life: Alyx is supposedly going to be unveiled today! Obviously it’s not Vaporware Episode 3 but it is something. :wink: Unfortunately it’s a prequel thing and focused on VR, etc. Not getting my hopes up of ever seeing a full-blown continuation or sequel :S

Anyways … as per your request, here is the video again:

For the other readers:
Please note that the test in this video was about the Fuel Cells specifically and not the Mines. The Mines do NOT disappear in this test. However, it demonstrates the common issue nonetheless in a reliably reproducible way.


Obviously I have no idea how the engine handles that so you may be right.

Render distance itself is an entire subject on it’s own for which I personally would like to see some options, if possible.


I don’t see any obvious LOD (Level Of Detail) models being used for these kind of objects. There is no obvious change in geometry when you walk farther away. They just get smaller and “poof” vanish. Of course, I may be wrong because it’s done so brilliantly that I don’t notice. But I suspect not.

As it seems now, the Scene Complexity is the setting which determines the distance at which objects pop into view. However, in contrast to vegetation etc, it definitely does not apply to objects like Gas Tanks. It is not the same distance for all place-able objects but Gas Tanks disappear at the exact same distance (of about 30 meters) regardless of the set value (low, medium, high, ultra)

I personally would like to see a setting which enables us (on PC of course) to change that specifically. Or possibly even more things. I would like to see a trap from farther away without having to ADS and I would like to see my grenade hit the ground too when I throw one. :slight_smile:

But like I said that’s an entire subject on it’s own.

How is it possible to lose your stuff when the game crashes? Every time your inventory changes the game is supposed to be saved. Or is that only when you re-arrange your inventory?

I have no idea! I’ve only had two crashes in all the time, and both times I was exactly where I was before… I thought saving was just when you went in Safe Houses, so what do I know?

Apparently, the DEVs are fixing about a 100 bugs, so we’re hoping this is among them. If not, then it’s back to polite agitation…! Thanks for reposting - it was good work.


I’ve also only had 2 or 3 unexplainable crashes since I started in August.

And a ton related to RivaTunerStatisticsServer (which comes with MSI Afterburner). And only after stopping (mostly) a (second) recording. Never did I lose any stuff or progress other than the exact world location.

Check the top right corner of the screen whenever you rearrange your inventory or pick something up. You’ll see the save icon flash.

It indeed also saves the game when entering a Safehouse but only when you enter it “manually”. If you fast travel it saves before leaving your current location. Which explains why you respawn at another location (possibly very far away) if the game happened to crash after you fast traveled somewhere else (or if you slam ALT+F4; which I conveniently did a lot when testing stuff).

Can’t really complain about that too much. I just shuffle my inventory when I want to set my respawn location. After all, it’s called a Safehouse and not a Savehouse. :wink:

It also saves when missions or objectives complete, if I remember correctly, and who knows when else.

By the way … did I just see my vanished Gas Tank in that Alyx-trailer? :crazy_face:
Besides the cringe-worthy humor, it actually doesn’t look too bad. Graphically pretty good even. But then there is … VR-only … grrrrrrrrr!

Heh. Those are the only reasons I’m interested in it in the slightest – good-looking VR games don’t grow on trees (yet), and we can reasonably expect good Index support from Valve.

Half-Life as a franchise I can take or leave. Mostly leave, really. Given that one of the obvious fits for VR is puzzle games, I’m surprised we haven’t seen a Portal game first, really. But then, I mostly remember Alyx as, “Hi, I’m Alyx, you go left to do the actual fighting, while I’ll go right to work the door locks,” and sure enough, HL:A shows Alyx doing some puzzles. :smile: At least it seems like we’ll get a protagonist who can talk this time!

I’ll probably get that one. Wouldn’t bother with another pancake HL game.


Off Topic

Can you elaborate on those? The RTSS, and the recording part? I don’t quite follow. I am also using RTSS in the background (as a frame limiter).

Yeah, that is kind of weird. The saving seems to be related to the door step or something. That is always the first/simplest approach and at some point you find out that it has weird side effects. That is the difference between event and state detection/monitoring. The question would be: Am I now in a safe house where before I was not? Has my state changed? How I got there would be rather irrelevant.

EDIT: In case the question was addressed to me: I lost stuff, because on inventory management I “parked” things on the ground. Because I was completely full and did not want to go above the 100/100. Because I am a loot goblin. :grin:

Aha. Well, I hadn’t worked out how the save works, so every time I want to be certain of hanging onto any given reorganisation, I leave the safe-house and walk back in again, just to be sure, Turns out it was a good strategy - who knew?

I’ve had a look at Alyx - pfff… A thousand squids for the headset, another for a new computer, but the game is free afterwards. I shall have to stick with GZ until I win the lottery.

As for Rivertuner, my poor little laptop (that I bought specifically to play GZ) gets too hot as it is. If I overclocked, it’d explode. The keys aren’t quite too hot to touch, but nearly!

Why would you move that bucket (just because you can) - movement draws attention! She could have learned that from GZ… Curious how the head-crabs exactly mimic Ticks. Or is it the other way round?

Maybe, they can both trace their lineage back to Alien’s facehuggers.

Off Topic

Yeah, VR is pretty expensive. And you should never get a setup just for one specific title. Reviews first, and then try VR at a friend and see if it is for you. Then, maybe then…

We are talking about the Statistics Server, which can be used to display info in an OSD, or limit frames in order to save power, or limit latency due to pre-rendered frames piling up.



To each his/her own :slight_smile:

I’m just not fond of all this prequel stuff. It’s basically a guaranty for screwing up the franchise and lore. Even the better ones (Bioshock Infinite, Borderlands TPS) didn’t really cut it, even though I still had a ton of fun playing them. But never even mind television series like STD. Besides, I’m not about to smash a 1000+ simoleons on an Index (and probably only to find out it makes me sick). HL was pretty good for the time and I have good memories from it. But it has lost it’s appeal for the most part.

I hope so. :slight_smile:

I usually start a buffered recording with MSI Afterburner (and therefore RTSS) when I start Generation Zero. That way I always have up to 10 minutes of footage from before the moment I actually press the “record button”. So, I can just enjoy the game without having to focus on possible upcoming interesting/buggy scenarios and not waste disk space at the same time.

Now, when a recording is stopped it returns to a buffered recording (and saves the actual recording). Usually that indeed happens flawlessly (but sometimes not).

When I start a second recording (within the same buffered recording session), all goes well until I stop that recording. Most of the times (but not always) the game then crashes to the desktop without an error report.

A pretty reliable precursor is when it takes a long time (up to more than a minute or several) to return to “buffered recording” mode. But, again :grimacing: , not always. I also had a few instances when it just CTD’d virtually instantly.

Before one of the updates (I think the September one) I did get error reports on crashes (but, you guessed it by now :wink: , not always). Sometimes it stated ntdll.dll as the faulting module but other times it stated SaveMedia64.dll as the faulting module. The latter being part of RTSS.

Whether the problem is because of a bug in the RTSS software, a bug in Windows or as a result of a fragmented (relatively) full disk or whatever, is hard to say. Since nothing is actually completely consistent and predictable.

The only consistency is that, if it happens, it happens when stopping a recording.

A trigger radius, I’d guess, since it would trigger also when you leave or otherwise be a very big doorstep. :stuck_out_tongue_winking_eye: My guess is that the proximity is either being checked before the player actually is there or the state of the player is such that the proximity doesn’t trigger anything. But then again, it may also be something completely different.

Actually it was and now I understand. :slight_smile:

I usually just swap two items. Works great. Just lifting and dropping a single item didn’t work in the past so I don’t rely on that (even though it shows the save icon) :slight_smile:

What kind of laptop, how “old” is it and was it new or used?

Laptops are notoriously warm (and prone to overheating) in any case, and GZ definitely lets your system work for its money (although that got reduced significantly I think) but “nearly too hot to touch” sounds like there might be something “wrong” with the heat dissipation.

If it’s quite a bit older (and assuming you don’t block the intakes and exhausts yourself) you might need to clean out the dust (plus dog/cat hairs) and maybe even replace the thermal paste here and there.

Off Topic

So you can record videos with RTSS, I never knew!

When I walked into my last safe house today, it triggered the save exactly at the door step. Will pay more attention to that the next time.

It seems it is enough to open and close the plundra for having the game save after a fast travel.

Well, this is what sysinfo shows…

I bought it new about, oh, this time last year, specifically as min spec for playing Gen Zero (i.e. just before GZ came out).

It is cool and quick doing anything else, but GZ stresses it a bit! But it hasn’t got slower at all, so it doesn’t seem to be suffering! It has a separate graphics card too, umm,

So, that’s my system, and I have to turn the resolution of GZ down a bit, and then it runs smoothly…

1 Like