dpc_Watchdog Violation

I was originally writing this as a reply to Endless crashing, please help!

I’m in the exact same boat. I really want to play this game, and have it not be a waste of $35, but it just keeps crashing. It seems completely random too. The first time I had played in months it worked fine. I was playing single player for a few hours. Then my friend got the game to play with me, and after I joined him we played for about 10 minutes before my game crashed. This has been going on for the past day while I’ve been trying different things to try and fix it, but at this point I’ve lost basically all hope. I’m sending this report as a last ditch effort to see if anything comes of it.

I’m playing on PC.

The first time my game crashed I was hosting a game that my friend had joined. We had just looted the house with the pistol, binoculars, etc. and I had gone to a small building towards the dock. I then turned around and had just started to sprint towards the orange car and I had just passed to the left of the phone booth. I was holding the starting pistol in my hand. My entire computer froze, but I can’t remember is in this instance it stayed frozen or if it went to the blue screen of death showing the dpc_watchdog violation. Either way the computer freezes up first, and I think every time my game crashes it is a dpc_watchdog violation.

The second time it crashed I was hosting again with my friend joining me. We had played for 15-20 minutes before it crashed. We went up the road to the police car with the objective marker on it, and looted everything in it including the runner on the hood. We killed the runner on the road with the objective marker. After that we went off the road into the woods towards a different police vehicle. We ran into some runners, some with shotguns some with the burst guns. I don’t remember exactly how many there were, but we destroyed them all, and destroyed the tick after it ran after us. We started looting the robots and the vehicles, but got attacked by a few more runners coming from the direction of the main road, and then after that some more from the opposite direction which was behind us. I think this time it crashed after we had destroyed all the robots in the area and we has started traveling down the dirt path some more and we were about a third of the way around the bend when my game crashed again this time freezing up then moving on to the BSoD with the watchdog violation error.

The third crash happened in a game where my friend was hosting, but as usual it was just the two of us. I don’t remember any other details about this one except that we had started back at the house again, but the loot, and the first robot on the main road had not been respawned, and we had decided to travel down the main road this time instead of going into the forest.

I then tried to play in single player again to see if it was just a multiplayer problem, and I was able to play for around 40 minutes before my game crashed again. I started by going from the house to the main road and travelling down it until I reached the first car wreck where a path splits off from the main road. I picked up the paper leading me to the hunter’s house, and I went straight towards it from where I had picked up the paper. I sneaked around the police car area my friend, and I had encountered before, and I went up the hill where I could see the hunter’s house from above. I then entered a prolonged fight with the three runners there by trying to lure them towards me where I had placed a couple of small gas canisters. I used a flare to try and get them right on top of one of the canisters, but threw it too far and ended up shooting the runners directly taking out two of them. I then snuck away from the third going down the road, and almost being spotted by another runner behind me that was inspecting the noise. I then snuck down in the grass off the road towards the hunter’s house. I hid in the shed next to the house and looted the ammo in there. I then waited for about 5 minutes until the third runner moved far enough away from me. I then snuck into the house closing the door behind me and went into the kitchen were a tick jumped on me, but I destroyed it. I found the rifle in the house, and soon after I found the scope. About a second after I picked up the scope everything froze again, and a waited for about a minute while everything stayed frozen until I just restarted my pc.

At this point I had given up on the game for the night, but this morning I verified my game files through steam, and tried to play again. When I started up the game it said it couldn’t retrieve a backup of my save, and I was forced to start over. I made a new character, and clicked start. I read through the intro story, but when it switched to the part about the students, and the boat being shot at I hit enter to skip which resulted in my computer freezing once again, and I had to hit the restart button to get out of it.

I then started GZ again, and it couldn’t retrieve the backup file like last time, so I made another new character. This time I skipped past the whole intro, and I was able to walk into the house pickup all of the stuff on the first floor, and the adrenaline behind the TV on the second floor, but when I had held the button long enough for the pickup bar to reach halfway for the binoculars and map my game crashed again.

My computer specs are:
CPU: I9 9900k running at 3.6GHz
Memory: Two 8Gb stick DDR4
GPU: GTX 980 Ti with 6Gb of memory
Mainboard: Z370 Extreme by ASRock
OS: Windows 10 64bit

Whole PC freeze or BSOD likely is not the game. This rather points to instable hardware (e.g. RAM) or buggy drivers. The watchdog thing often happens if you overclock your CPU with too low core voltage.

With your 9900k running at 3.6 GHz you mean it is not overclocked? Did you change anything in the bios overclocking section?

PS: I basically read your title and your PC specs due to the wall-of-text issue.

I had a hunch that it was the game because it only happens when Generation Zero is running. I have not overclocked the CPU. My friend keeps telling me that it could be an issue with the memory, so I might try switching it out for something newer since it is getting a bit old.

Also sorry for the super long post. I was trying to get a bunch of detail surrounding the issue, so if the devs could do anything they would have access to a lot more information.

The errors people get here tend to be memory access violations, so it could be that setting off your watchdog. If you’re concerned about RAM, run memtest off a usb thumb drive. It’s pretty neat, and very thorough.

Edit: I didn’t know about the HCI Memtest below. That’s even more relevant. Good one!

1 Like

I would like to add to that memtest86 is very good at finding broken RAM modules. It is however, not very good at finding RAM instabilities. That is HCI Memtest’s area of expertise.

For that run as many instances as your CPU has threads. Reboot your system and close any unneeded applications. Take your total system memory, subtract 2 GB for the OS, and divide the rest by the number of threads. Start each instance and let the whole thing run until you reach at least 400% coverage - better are 1000% coverage in case of rare issues. You might want to do that overnight, it can take a while.

In any case it is always good to try and go for memory that is on your mainboards QVL (qualified vendor list) of memory modules.

PS: Memory too old is not really a thing.

EDIT: After you have tested your PC with both programs, let us know and we’ll come up with more suggestions.


I’ve had hundreds of crashes at this point but none of them has been a BSOD.
Many times before the Alpine update the crashes would not be caught by crash reporter.
This would make the computer look frozen, but ctl-alt-del could get me to task manager where I could see that behind the full screen game was one of those “This program has stopped working” windows. Those are always memory violations in Event Viewer and Crash Reporter can’t snag them. Rather rare now, probably less than 5% of the crashes. If you get a crash that doesn’t quickly drop to crash reporter, CTL-ALT-DEL out and see if there is a “Program has stopped working” window and if not, just wait a while. Reason is that sometimes it takes a while because it is doing a memory dump. Sometimes crash reporter will actually show up and close out the game after a few minutes.

GZ was dumping 8 gig memory dumps at every non-Crash Reporter intercepted crash, really messing with my SSD and leaving me with 0 free space on my system drive. I made a change in registry so it could do the mini-dumps instead and that took care of that. Still it can delay for a while as it writes the dumps and the game won’t close out even with a force exit while it’s doing that. It can also not really let you get to Steam or any other application while it’s doing that. If you can get to Task Manager, don’t try to force exit the game and just give it a while because if Task Manager is up then you’re not dead in the water! Well, in the game you are but your OS is still kicking.

Saves a lot of potential system trouble to just wait a few minutes if you can. If your system is doing the full dumps instead of minidumps it could take quite a while for it to write and it would be best to disable that if you are going to keep fighting with this game.

Obviously if you get a BSOD or total freeze so that you can’t even invoke Task Manager then all this advice is moot.