Error, D3D Device lost!

Steps To Reproduce:
Occurs randomly, middle in the forest, after a fight, inside buildings.
Host or Client:
Client and solo
Players in your game:
1 and solo play
Windows 10 Home 64-bit
i7-5820K CPU @3.30 GHz
16GB ram
NVIDIA GeForce GTX 1080
Monitor: ASUS 2560 x 1440 144Hz G-sync

Bought the game 3 days ago on steam with my partner and we have been playing togheter since then, but every so often my game crashes and this error message displays:
Error, D3D Device lost
Device removed, reason: DXGI_ERROR_DEVICE_HUNG:
Graphics device stopped resopnding. There might be an infinite loop in a GPU program.

I’ve tried the following:
Verify integrity of game files: no go
Run as admin: no go
disable Fullscreen Optimizations: no go
DSR off: no go
Nvidia control panel Manage 3D settings:
Program settings
Open GL rendering GPU, Geforce GTX 1080: no go
Power manager mode: maximal performance: no go
all of these trial and errors I found on various sites that was similar to my problems but no joy.
I’ve doubble checked that Nvidia drivers was up to date and DirectX and I have the last drivers of both, tried a clean installation on both drivers to be sure I had the last drivers and tried to run the game but no joy.

I can play for 5-10 min before it crash and sometimes 30min to 1.5 hours so the occurance is randomly.

I hope I can get som help because I love the consept of the game and the mechanics, and I will not give up hope on the game just because some bugs and crashes.

3 posts were merged into an existing topic: Various D3D Errors Windows 10