First mission of FNIX rising

I recently bought Alpine Unrest and FNIX rising dlc’s, while alpine unrest works completely fine i cant see the first fnix rising mission anywhere, ive searched it up before but none of the tips work and the location where it should be is not there, please help.

Try travelling to Asotungan Outpost. I can’t remember how it started, maybe via proximity. I know that for the first mission you need to go there. But you should have the mission in your missions log.

It is called “Where the Sun Sets”

If you find out how, Please let us know, so we can re-update our knowledge. :coffee:

I have tried that but it still doesnt work, its not in my missions log either so i really dont know what to do image

You do have the DLC…?

When DLC is installed/activated, it opens up the FNIX Rising missions. And also places the mission items in the world. If that does not happen, something is wrong. But check if the DLC is activated.

alright ill do that, i know i bought it yesterday with alpine unrest and the base defence pack so i know i at least have it

If you are on Steam, there is a DLC manage spot on the game page. I don’t how it works on other platforms.


Take a look at his first screenshot. He’s on PC.

But is he on Steam or gamepass? :smiley:

To be true, not sure. I assumed that game pass version also shows xbox button icons…

Here how the log entry should look like:

And here is more info about fnix rising:

steam. Also it works now

1 Like