Force fps upper limit please, the uncontrolled fps causes my computer to thermal crash

First, yes I know I am using a very difficult cpu, however the uncontrolled fps causes my vcore-1 to hit 70c in less than 10 minutes. i dont know if this is due to the recent update, but I was playing fine on the free weekend. so much that I bought the game.

My cpu is amd fx-9590, motherboard is asus sabertooth 990fx R2.0

I was able to play perfectly before, limiting my settings to save my heat generation, but even now on low everything and reduced resolution the game hits 120fps and keeps spiking my temperatures, there is no thermal throttling that I can figure out with my motherboard that works unfortunately.

Please allow me to set a maximum fps limit so that I can enjoy the game again.

You could try msi afterburner

something in the update caused this to crash my computer. idk if its the target fps thing was changed, but after the latest update I cant play for longer than 20 mins.

Please provide a more detailed PC specs and your monitor refresh rate.

Not to be “that kid” but maybe you should invest in a better CPU and/or fans (or possibly better RAM). Obviously, that wouldn’t solve the whole problem, but the slowest component, pretty much makes the whole computer that slow. So, this might solve part of the issue.

I play on console, and do experience some major lag at times, but almost never crash due to anything but a glitch in the game. So, of course because I don’t play on PC, the glitches might be different, but the component suggestion still holds water.

Already in the game.

Settings → Display → Vsync + Dynamic Resolution + Dynamic Resolution Target FPS.

Besides that, there are several other options to limit FPS within Win 10. But that discussion can take place in here: Some change causing runaway thermals ending in crash

With requested feature already present in the game, topic closed.