Some change causing runaway thermals ending in crash

Platform: PC

Description: running the game causes the temperature of my vcore1 to reach 70c within 10-20 minutes causing a thermal crash. I have lowered all the settings, reduced resolution, and still the thermal runaway continues. I have noticed that regardless if I set the target fps to 30 the game still hits over 100-170 fps, disregarding the target fps and I believe causing the thermal crash.

Steps: Play on my computer, doing any activity in game.

I have only tried this when joining a multiplayer game, I have not tried solo.

Players in your game: happened with 2 and 3 players

Specifications: AMD 9590 fx, motherboard asus sabertooth 990 R2.0, video card Rx580 OC, 16gb ram

Here’s your issue.

AMD FX-9590 has a TDP of 220W, with stock clocks. :scream:

And to cool all that, you’re looking towards 360mm or 420mm AIO rad, where open loop would be preferred. You may get away with 280mm rad AIO, if you get a good AIO but anything less of that will cause you thermal issues.

At this point, and rather than dishing out pretty penny to get proper CPU cooler for that furnace, your money would be much better spent by buying new CPU-MoBo-RAM combo.

While I appreciate the comment, this game was able to run perfectly without issue for hours before the update.
I will admit that the ambient temperature was a little colder, but the only change was the recent update.

“Please provide a more detailed PC specs”

What are you looking for? cpu is 4.7ghz, monitor refresh rate is 75hz but I set the target to 30. however the target doesnt affect actual refresh rate as shown by the in game counter. it is always much higher.

In the recently closed topic, that feature does not work, the target fps rate has always been exceeded.

Turning on Vsync will usually lock the frame rate to your monitors refresh rate. If your monitor is 75hz, then it should not go above 75.

Yeah I tried that, it did not work.

Which update?
Win 10? Radeon drivers? GZ itself? All three combined?

Ambient temp is always lower than what you have inside the PC.

How about capping the FPS within Win 10 settings? :thinking:

E.g AMD FRTC, among many.

Frame Rate Target Control (FRTC) is a new option in AMD’s Catalyst Control Center that lets you set a maximum frame rate between 55 frames per second and 95 frames per second (fps) for the majority of DirectX 10 and DirectX 11 games.

Article about it: Tested: AMD's Frame Rate Target Control delivers real benefits for Radeon gamers | PCWorld

I have uploaded a video showing that the target fps has no effect on actual fps. I believe it is intended for control the other way, i.e. if your machine cant quite hit that number normally it will lower the resolution in order to achieve the requested fps.

The latest update to the game, approximately mid march, coinciding with the news of the base building update.

The lower ambient temperature was referring to the winter, the room was colder at that point, I am aware that the ambient temperature of the room will always be lower than my computer.

It is a possible workaround to try and cap the fps outside of the game, I have not done so as some games do not give me this issue, I need to adjust on a per game basis because of my specific choice of CPU.

I will look into AMD FRTC and the others, however I am fine playing at 30fps, which would be optimal for my difficult setup. the reason being that the difference between 75 and 55 is lesser than 75 and 30 and I’d prefer to limit this game to 30 amazing frames per second instead of 55 semi potato frames per second.

Thank you, I hope you understand my feature request now that you see the video.

I’ve fixed the video now.
I’ve shown that the “target fps” doesnt ever allow the actual fps go down, or below the vsync or current fps

Regarding that, you need to link the video url, not the Youtube Studio url where you edit the video.

There were no GZ updates mid March, so it can’t be the game’s issue. Last GZ update was in February '21, 15th to be exact. Patch notes: February Update - Patch Notes | Generation Zero

So, there must have been some other update that caused your issue. :thinking:

About a week later from when Systemic Reaction released the news about upcoming base building (18th of March '21), the Adrenalin 2020 Edition Graphics Driver 21.3.2 was released (28th of March '21). That falls neatly into the time frame where you started to have your issues.

Also, we have had other people here, with Radeon GPU, who had have issues with Radeon drives. For many, rolling back the GPU drivers a version or two have fixed it for them. Topic in question as well: Experiencing freezins/frame hiccups after fighting monsters, after running (PC) - #7 by radikul

If you’re running latest Radeon drivers, give the downgrade a go. :+1: Uninstall the current drivers with DDU (to remove all lingering files) and then install older GPU drivers.

I have updated the video link, thank you for pointing that out.

There were no GZ updates mid March, so it can’t be the game’s issue. Last GZ update was in February '21, 15th to be exact

I dont know this is true, I remember seeing steam update gz prior to the issue manifesting. but I dont know if this is a steam thing or the game, only that I saw it in my update queue. perhaps a misunderstanding.

I have capped the game at 30fps with radeon settings and the issue has dissappeared, however I feel my feature request is still valid. asking the game to set a maximum fps is reasonable, but as this is already possible via other means I understand it is not needed to ask the devs to do more work.

Checked your video and the FPS counter is so small, that even in full screen, i couldn’t tell what it showed.
Steam FPS counter is nice and all but if you add two screens next to each other, it shrinks it way down.

There are other, in-game overlays, that show the FPS + CPU/GPU/RAM usage + CPU/GPU thermals all in one and in bigger format, so you don’t need to show two screens. I don’t know if Radeon drivers have in-game overlay but Nvidia drivers do have it (part of the Nvidia Geforce Experience) and other utility programs also have in-game overlay. E.g: my NZXT CAM has it and so does MSI Afterburner.

As far as your CPU thermals go, i saw it started out quite high and during the loading, it dropped some. But within the game, it started to rise again.

When was the last time you cleaned dust from the internals of your PC? Also, i’m now interested, what kind of CPU cooler you actually have? :thinking:

Another question but irrelevant to the current issue: Do you have OS and GZ on HDD? Since the loading times i saw in the video were very long, :astonished: about 4 times longer than i have it (i have my OS and GZ on Samsung 960 Evo 500GB M.2 NVMe SSD).

Well, like i showed you in your other topic, there is a way to cap FPS in game. But since it didn’t work for you, there is no issue of “adding” it. What could be the issue, is “fixing” it.

Though, what i do not know, is if that FPS capping in-game is hardware dependent. Since if it is, i don’t think devs should spend their time to make it compatible with old hardware, that anyone would be using as of today. Well, except you. :grin:

Nice to hear that you got your issue solved. :slight_smile:

even in full screen, i couldn’t tell what it showed.

if you have dual monitors, drag the window across both monitors and select theater mode from the video. this will enlarge the video across both screens. although captured at a higher resolution, I am not youtube savvy enough to know why it was only posted in 720. however at the expanded view across both monitors you can see the fps counter stay at 75 until vsync is turned off and then it climbs to 170+.

As far as your CPU thermals go, i saw it started out quite high and during the loading, it dropped some. But within the game, it started to rise again.

Yes, the temperature was high because i had just tried multiple times getting the capture right.

When was the last time you cleaned dust from the internals of your PC?

last month

Do you have OS and GZ

no both are on separate ssd’s, but not nvme

like i showed you in your other topic

you showed a screenshot, not any setting influencing the framerate. my video shows that this setting is not working for me, or perhaps that the setting is intended as a minimum threshold not an upper limit.

Well, i don’t.

Are you using an AIO? :thinking: Since tower-type air cooler wouldn’t hold the CPU temps high after heavy heat output but AIO will. It takes about 30mins for an AIO to heat up and same time to cool down again.

Tested it out myself (just to see if it has any effect) and for me, Dynamic Resolution enabled with target FPS either at 30 or 60 didn’t affect my in-menu FPS. So, it is possible that it is min FPS, rather than max FPS. :thinking: The in-game description of it isn’t clear in regards of this. :unamused:

However, enabling Vsync did have an effect. It dropped my in-menu FPS from 236 down to 144, to match my monitor Hz rate.

Some other thoughts:
Since GZ, as a game, is not a “finished product” but instead a “live service”, (like e.g Win 10 is) game is getting additions as time moves forwards. Latest update (February '21) brought us FMTEL stations, connectivity to Apex Connect and possibly pre-setup for upcoming base building. All the additions, compared to launch-day GZ, add up and in turn, also require more processing power from CPU/GPU.

Modern hardware can easily cope with the changes and toll on them isn’t that big, if even noticeable. It’s the older hardware that struggles to keep up. And when it comes to hardware upgrade, most of the times, it isn’t replaced because they broke but instead because they can’t keep up with more demanding tasks.

Are you using an AIO?

no, I’m using a big air cooler, 2 fans in push pull with 2 support fans around it, one behind pulling and one above.

The temperature I was monitoring is vcore1 which is technically behind the cpu and provides the power to the cpu, this is the thermal bottleneck but for my uses its good enough.

Tested it out myself

your experience is exactly my own. This is what I meant when I asked for a fps “limit”, but as i said before i guess its irrelevant as other utilities can handle it.

Regarding why I chose this cpu, I needed high speed, lower number of cores for my application (parametric modeling, which isnt optimized for multi-threaded cpus yet). additionally, the cpu and MB were both cheaper than either component of equal performance in the current generation. the downside is that since my cpu “runs” at 4.7Ghz every game thinks it can run at ultra without issue and I havent found a reliable way to automatically thermal throttle based on cpu or other mb sensor temperature.

Well, i don’t.

As an alternative, you can open the window, move it half off the screen, then manually expand the window from the side and repeat until the height roughly matches your current monitor.

Big, as in e.g NH-D15 or Dark Rock Pro 3 or “big” as in Arctic Freezer 30-series? :thinking:

Vcore1 is your CPU’s 1st core, and not the socket or CPU clock and control unit.

Speaking of CPU clocks, have you ever tried to underclock your CPU? :thinking: E.g down to FX-8350 levels? Since FX-9590 is basically FX-8350 but with a huge factory OC on it.

With lower clocks, you’d also have less heat output and in turn, better performance in games, since you don’t have to cap the FPS anymore. :slight_smile:

High core frequency isn’t everything. IPC (instructions per cycle) is far more important. Since even when you have high frequency, the low IPC will be the final nail in the coffin, where CPU with good frequency and IPC will outperform it. E.g i7-4770K,
comparison: UserBenchmark: AMD FX-9590 vs Intel Core i7-4770K

Back in the early 2013, FX-9590 MSRP was $920, while i7-4770K MSRP was $350. :thinking: I don’t know about you, but paying almost 3 times the price for a worse performing CPU is a huge waste of money.

Tried that and that doesn’t work. Win10 doesn’t allow me to widen the browser (FF and Chrome) past the resolution width i’m using (1920p). I don’t recall this being an issue in with older OSes (Win7 and WinXP). :thinking:

One thing that comes to my mind regarding your high CPU temperature might be the very old thermal paste between CPU shell and cooler. If you remove the old thermal paste and apply a fresh one this can help dropping a few degrees.

GamersNexus made a video a month ago about repasting GPUs. Although it’s not about CPUs the principle applies to them also: GPU Cleaning Before & After Thermals: Re-Pasting & Dust Removal - YouTube

This. Also, you could try undervolting the cpu.

Since OP’s FX-9590 is a 220W CPU, changing thermal paste has little, if any, effect to the cooling of CPU. But it’s worth a try.

Here’s a video how to do it with CPU: