I can't log in to play the game AT ALL

Platform: PC Microsoft Store.

Description: when I launch the game, it asks me to sign into an Xbox account. When I do, it just says “You must be signed in with a profile to play” and sends me back to the same screen. The only two options are to select a profile again or quit the game, so I don’t even get the option to play solo. I have uninstalled and reinstalled the game 3 times, moved it between drives, reset my data on the game, the Xbox software, and the Microsoft store, and have signed back into them all, but can not sign in to play the game.

I came to Microsoft support for this, since I assumed it was a Microsoft problem. I battled with Microsoft’s awful support for 3 days, and was put through 2 “support gamers”, their awful AI support, and then FINALLY an executive specialist, and they just told me it must be a problem with the game. They messed up my computer when trying to fix it, fixed my computer after an hour to get me back to square 1, and then tell me they don’t know what it is and it must be a problem in the game.

I have been trying to play for 4 days and haven’t been able to, before just joining the GZ discord yesterday and nobody appears to have the same issue, please help, it’s such a cool game and I just wanna play but I can’t.

Steps To Reproduce: Open the game and try to log in.

Images / Videos: This is the error I get when trying to log in: https://i.imgur.com/soYCpII.png
And then it sends me back here, with no other options than to try again or quit: https://i.imgur.com/JayH8Rt.png

Host or Client: The Game Itself.

Players in your game: None, not even me. :confused:

Specifications:
Motherboard - ASRock Pro4-IB
GPU - Gigabyte RTX 2070
CPU - Core i9 9900K
RAM - Vengeance 64GB 16x4 3200MHz sticks

What’s your OS?
Did you install the most recent update of GZ for Microsoft (Xbox/PC) which was released yesterday?
What about other games of the gamepass? Can you play them or is there a similar issue with your profile?

I am on windows 10 Pro, and I am not aware there was an update yesterday but I did uninstall and reinstall the game yesterday so I might have, I’m going to check just in case. Yes I can play my other games, Things like ARK, Slime Rancher and Halo Wars work just fine

It did not work, and there were no available updates

Well, you probably just installed the updated complete package. What’s your game version? Can you see that in the gamepass app?

Just in case it’s possible/available for the gamepass version:
Did you ever use some kind of mods for GZ?

Did you also try to reinstall the whole gamepass app?

You could send a report to the gz-support-team.

https://support.generationzero.com/hc/en-us/requests/new

@SR_Carni I wasn’t able to find more support topics there for what to do in case there are issues for PC (gamepass). Do you have some more ideas? Are there any known issues?

1 Like

I have uninstalled and reinstalled it, cleared the data on it, the game, the Microsoft store, and gaming services as well. The game says its on Ver1.0.1040.0, and the check for updates button does nothing. I have also tried verifying and repairing.

I don’t know of any issues, I have never used mods, and didn’t play the game all the time. I recently just tried to get back into it 4 days ago and that’s when I found the problem

Did you try to delete your old safegame folder?
These folders in general aren’t deleted just by uninstalling a game. Make a backup before.

Do you use any special antivirus software or firewall that may block GZ from communicating with the servers?

I did, and no I just have the normal windows security, with defender turned off

Have you checked that the drivers are up to date, you had a similar case here where the graphics driver was around 2-3 years old. Maybe it will solve the problem.