Impossible to complete "Numbing Expert" challenge

I’m trying to complete the “Numbing Expert” challenges, which shouldn’t be too difficult as I can use the sensory jammer to block the bots from seeing me, however, I and many other people trying to complete this challenge after the March 27th patch CAN’T. BTW I’m on PC.

The bug is where, no matter what you do, the bots ALWAYS instantly “spot” you and you have the “Entered Combat” pop up at the top of the screen. If the sensory jammer is not active they will spot you as soon as they aren’t stunned anymore, or if you do have a jammer on they somehow have the detection bar maxed out but won’t start attaching you until the sensory jammer wears off.

Before anyone asks, I have tried EVERYTHING in Aesyle’s guide but can’t get a single “successful” disable on the first tier of “Numbing Expert.”

I would love it if this could be fixed reasonably quickly.

Edit: Below is a link to the unlisted video showing the bug so you can see what I’m talking about. BTW, I show the challenge thing at the end as I forgot to look at that right after I EMPed the seeker.

Link: https://youtu.be/7qus08HtW7g

Where did you try it?
I’d suggest to do it in a region where no soviets are.
Since Landfall update the machines also go into “in combat” state, if they are attacked by other machines.

The jammer came later. I don’t know if it was included in this challenge correctly… Or maybe it’s just really bugged.

I was in the archipelago region EMPing prototype class hunters. I would also like to mention I was using clothes that have maxed visibility reduction, prone crawling behind lone hunters, with no other enemies to be seen, haven’t engaged in ANY combat, and have a sensory jammer active, but they “spot” me as soon as they are hit and as soon as they aren’t stunned anymore, then attack me after the sensory jammer stops.

The only time they didn’t immediately come and attack me was if I ran away and hid in a building while the sensory jammer was still active.

Which kind of EMP did you use?

A direct hit is registered as attack which triggers the “in combat” state.

I have used every EMP (car batteries, EMP rockets, EMP grenades from a DLC, small, medium, and large cells) and I have been throwing them near, but not hitting, bots or will shoot a placable EMP with a silenced .270 from far away with a sensory jammer and they still agro. I’ll post a video in just a moment.