Invalid Version as host?

So I’ve been playing with someone for the past few days usually goes fine, flawless but today i encountered an issue which has made the game next to unplayable for me. Out of nowhere whilst killing machines, looting or exploring id just randomly get kicked out of my own game with;

“Invalid Version
The multiplayer session that you attempted to connect to is running a different version of the game than you”

Now this is confusing me as i am Host and there seemingly seems to be no fix as resetting my game completely and attempting to play again just seems to replicate the issue at a random time with seemingly no obvious trigger.

for Added Detail the person I’m cooping with has stated his version of the lobby stays up despite not being the host and if this happens during a fight he is able to kill them but cannot loot or do anything else.

Currently playing on W10 on the Steam version.


Same issue here. playing on windows 10 version from the Microsoft store. Had 0 issues with it until 4 hours into playing today.

Same issue. I restarted my game and lost only the destroyed machines that were on the map before I, the host, crashed. And this is with more than one runner pet out and in play. I had myself and 3 players and I think 3 pets were running around. The game still crashed, for the host, when the pets are used.


Same, Been playing with my Son for about a week now and today this started. Does not matter who is hosting, the Host always gets the error of Invalid version

Same issue here. First time this happened after 100 hours of gameplay, but since it happened once it seems to happen every time.

We play the game with Me (host) and my brother (client) and my Runner companion. It’s always the host that crashes (at least in my experience).
Platform: Steam/Windows 11
CPU: 13900K
RAM: 32gb DDR5 6400Mhz
GPU: ROG Strix 4080
Game version: v.2577741

Tried finding some possible clauses, reinstalling the game didn’t fix the crash, 25 minutes of idling didn’t crash it (even with companion), neither did fighting in general or against rivals (apocalypse hunter and tank).
But a few seconds after engaging with a level 2 soldier class rival firebird the game crashed.

Before the first crash happened we were fighting enemies for approx. 30 to 40 minutes with no issues, but when fighting the firebird the game crashed. Every crash after that one was when engaging with a firebird.

Hopefully today’s hot fit addressed this issue.

Thank you Dev team!

Tried booting the game again to see if the hot fix managed to fix the issue.

Although this time we went 30 minutes without a crash again, fighting 2 firebirds in the process, but the 3rd firebird we fought crashed the game when I shot around 10 .50 bmg rounds in it from my EXP .50.
Same “Invalid Version” “The multiplayer session that you attempted to connect to is running a different version of the game than you” as before.

I’ve started getting this since the last patch every now and again. Also I’ve noticed that the game has gotten worse since the last patch, I’ve lost what seems like 10 to 20 FPS.

Same issue
**Platform:PC running game through GeForce Now

**Description:as above multiple disconnects by host due to ‘invalid version’

**Steps To Reproduce: happened multiple times during gun fights

**Players in your game: 2

Did one or both of you use the companion during the Fights?