It won’t let me join

The game is saying joining game loading world. It has the persons name on the left side bottom it won’t let me join the game at all. What should I do?

The screen shot does not match trying to join a multiplayer game.
From the background image, you should click on MULTIPLAYER, which brings up a menu screen where you select number of players, difficulty, language and so on. Then then the loading world icon with a black background. As the map loads the players on the map starts to show up then.

But it looks like that if you follow an invitation… At least I can speak for playstation.

Did you follow the invitation directly from dashboard or from within the game? In the past my mate and me had issues when trying to follow an invitation from the dashboard, but if we started GZ first and then followed the invitation, it worked well. Just an idea.

1 Like

Right. On console, if you get an invitation or go to join a friend directly from your list or whatever, this is how it goes… Usually it will load in, and play normally, however.

In the case of a lock-up like this, it may be related to the fast travel infinite loading/lock-up glitch.

I had a situation some time back where I was unable to join other player’s games, just like this.

I could get into my own world, and invite them to join me, without issue. However, if I tried to fast travel from the location my character was at my game would lock up, I’d get caught in the infinite loading screen. The location I was at was the Rusaberget Lake Camp, if I remember right—north of Sandbo, border of the Farmlands and Mountain regions, east of Uttern. I had to physically move away from that location, then I could fast travel, and then I could join the other player’s game without this issue the OP is having.

So, when someone has trouble joining multiplayer…I would suggest loading into your own world, moving to another location (swap safehouses), then try joining them again. May work—or it may not, if the issue is different.