Maintain Asset Cap

I don’t know if this is a bug but, I built a large base I was able to repair after attacks, but when the machines started completely destroying assets like, say, a pylon, I found I couldn’t replace them. I know I’m at the limit of some assets (tall walls, pylons) but shouldn’t I be able to replace an asset and still be under the asset cap?

Windows 10 64 Bit
CPU i7-6850K
RAM 32.0 GB
GPU 3060

Did you have enough resources to build another one? :thinking:

I guess you want to build a corner post or piece of wall. If that is so, do note that in the “Walls” section, there are more base modules that count towards the build cap.

Current base module limits are as follows:

150 - walls (corner post, low wall, high wall, all three shooting targets, banner)
10 - gates
5 - pillbox
10 - watchtower
1 - stations (one of each)
25 - lightning (light pole, lantern)

E.g, if you have 30 shooting targets and 20 banners built, then you have 100 left for walls.

Well, you can either:

  • repair the damaged module
  • dismantle the module (damaged or not) and build it again

Though, there are some spots, at the outer edge of the build area, that are too sloped for placing most modules. It’s something to look out for.

Btw, are you using any 3rd party mods?

The pylon was gone. The Runner got too close to the wall and when I inspected the base the pylon was missing. All I could do was replace it but the game wouldn’t let me. In the end, I had to shorten my design by one grid on the long end so I would have a spare to fill the hole. Yes, I use mods.

A little history - I had a design I really liked but, after seeing a friend’s base, I decided to make it more compact. But, I found it was too hard to get around quickly so I tried to go back to the previous design. That one actually used 4 more tall walls that I couldn’t recreate in the current design. I think something is actually affecting the wall cap - as I said, maybe too many rebuilds?

Uninstall/delete all your mods and for good measure, reinstall the game as well. Since there is no official mod support for GZ, 3rd party mods can do all sorts of strange things.

I’m not a dev. I’m just a fellow player who has been in the forums a long time and seen all sorts of things 3rd party mods do with the game. And so far, removing the mods have fixed things.

Do note that some mods live in your Documents folder, near your profile save data and reinstalling the game doesn’t remove the mod files there. So, be sure to remove all traces of mods.

//mod removed a comment to keep talks about mods to a minimum. This bug doesn’t seem to be caused by mods.

Thanks for your help. I’ve flagged my post to have it deleted. Looks like I just miscounted. You should’ve seen me running around trying to count every wall asset and getting a different count for the tall walls each time. You’d think if I got it wrong it would be for the pylons. Anyway, I went down this rabbit hole because I think the game let me go over by one! That’s why, when I tried to replace the destroyed pylon, it wouldn’t let me.

:smile: You’re welcome.
And while i did thought that you could’ve counted wrong, i had faith that you counted correctly. :wink:

Since the issue was resolved, I’ll be locking this one.