Make Some Noise Mission Bug

So I’ve brought up this matter twice several months ago where whilst playing the mission “Make Some Noise” and completing the objective “Gather old papers in the building at Tarnboda skans” my game crashed and when I reloaded the mission was set back to the objective above with 3/4 papers already picked up but when I tried to pick up the last paper it was nowere to be found. I tried reloading my game, my xbox and tried uninstalling several times but I am still unable to progress/complete this objective. It has been a few months since I brought this up a second time and I had hoped it would be fixed with the amount of updates it’s had since but unfortunately it has not been patched/fixed. I really enjoyed playing this game and would hate to have to restart and lose all of my progress and I’m still wondering if this matter has been brought up with the devs and if there’s a fix that doesn’t require the loss of my progress?

A post was merged into an existing topic: “Make Some Noise” quest bug