Medkit Bug/Glitch(?)


I’ve started playing Generation Zero® since yesterday, and just discovered / experienced a bug today. [Info: I’m playing on a Ps4]

So, I was just doing some side quests and killed some robots. I was pretty low on health so I used a Medkit and switched to my gun again. My gun wasn’t displayed, but a Medkit was, and It said that I was still on my Medkit slot (the slot was empty/didn’t show an image of a Medkit). I checked my inventory and there weren’t any Medkits. I tried to use them and it worked and it didn’t dissappear too. I killed myself by jumping off a rock and after I respawned they were still there. I tried switching again but nothing happened. I tried to lose it and luckily came across a guncase. After I took out the gun the Medkit disappeared.

That’s all.

I have a similar issue with Advanced First Aid Kits, where they stick to my hand
The easiest fix is to find another medkit of the same type and then unequip it
Or jump off a building :+1:

1 Like

I actually jumped from a hill and died, but had respawned and they were still in my hand. :thinking:

I had this happen once, while assaulting a Destroyable Fnix Base alone

After deploying my last Air canister from inventory screen
for some reason my character picked up another gadget in their left hand as i switched to a weapon to use it to blow up a wall.
Which were a Heavy noise maker, turned with the top facing me so i barely could barely see anything as it took up nearly all of the screen <.<
though i could see if i Sprinted around while holding a medkit
(as a runner found and shot me…)

So i ran out of the base and hid in it’s vicinity
and lost the atleast one runner chasing me and i tried to figure out how to get my character to unglue the Heavy noise maker from the left hand…
(which were not in any equipment slot)
I think i tried to equip it but that didn’t do anything…
But Dropping it on the ground in backpack did
and i could even safely pick it on again, without it ending up glued to my characters left hand again ^.~

1 Like


1 Like

The only other way is to pick up a similar item and do what @Zilem said

1 Like