Missions have disappeared from quest log

Platform: Xbox Series X (the new Xbox)

All my missions have disappeared from the quest log, both main and side missions.

Steps To Reproduce:
The issue seems to have started when I joined another player’s game in multiplayer. After joining his game, 6 achievements immediately popped as finished. All these achievements were for quest missions I had not yet completed in my own game. When I returned to my own game, all my missions were gone except for the 2 DLC missions I have not done.

Images / Videos: I have uploaded 2 photos of the in game log. There are no photos for before the issue occurred as I don’t take pictures of the mission logs in my games.

Host or Client:
I joined another player’s multiplayer session on Xbox. I’ve since joined 2 other player’s sessions and this issue persists.

Players in your game: 3 as well as sessions by myself.

Specifications: Xbox Series X

Steps I took to correct the issue:
-Quit the game entirely, then restarting the game. No joy
-Quitted the game, restarted my Xbox, then restarting the game. No joy
-Shut down Xbox and did a power cycle. Still no missions showing after restart.
-I completely uninstalled the game. Restarted the console, then reinstalled the game. No joy.
I am aware that this issue was more common a year ago as I cannot find any recent references to the issue anywhere on the internet. But that said, I also cannot find any posts that say the issue was solved. Clearly it has not been. Since this is the case, I don’t think I’ll be playing anymore as the game is just too flawed and I don’t relish making a new character just to find out the game still doesn’t work. Too bad as I was enjoying the game until this happened. So here’s the bug report.


1 Like

This also inadvertently happened after the Alpine Unrest DLC.

I had completed the whole DLC, and invited another player who had the DLC - but not visited it yet.

He had all the achievement’s unlock, but don’t recall losing mission progression.

I managed to get back the quest to find all the bunkers and unlock the warboards. I’ll work on that one and see if that cures the problem. No sign of any of my side quests yet.
Still seems very weird that they haven’t addressed this in a game as old as this one.

Glad to hear you were able to work it out. How were you able to get the missions back?

I agree, though it’s possible that it is simply an issue that is difficult to re-produce.

1 Like