Multiplayer Desync Issues

I don’t know if its been reported, but I was playing Gen Z the other day with a friend who to be honest, is not a fan of the game. (Sorry, but such people do exist.) We were going to do a base defense with my world when before I could start the mission, parts of my base just started exploding and collapsing. My friend then said that he was being shot at. I realized that he was seeing the enemy base that had been destroyed and taken over by me. I tried everything with him to try to fix the issue. We both restarted the game, I joined him for a bit to complete portions of the game. I know that the mission Good News was how it used to be started, but I don’t see that available now, so I’m guessing it would be Building Blocks. But I didn’t know where to go to start that mission. He definitely didn’t want to play long enough to pick up the mission by default. With me joined to him, we jumped to the area with the enemy base and started to attack the base, but since we hadn’t started the base mission, the generators were not there to destroy.

We were both frustrated at this point, I wanted to keep troubleshooting, but I had no ideas left. Now he wont even talk about playing the game again. I just wanted to know if this had been reported before and if so, is there a fix?

On a side note, my daughter was able to join the mission in my world and it worked fine for her and she’s done none of the base missions.

Thank you for any help. :grin:

  • I just wanted to stress that we are both PC/Steam players