Multiplayer is bugged

Every time i try to host or join a multiplayer session with friends it will either make my session offline after a 5-30 minutes or kick me out the session I joined for the same time degree, this has been a issue for me since the addition of the 3 new experimental weapons, I tried resetting wifi, console, game, even uninstall and reinstall yet multiplayer will still not work for long sessions, i dont know what caused this as i have strong internet plus wired connection, so if u could look into why this is happening it would be amazing because me and my friends love this game but can’t enjoy it together due to multiplayer being bugged

You could try using a cable instead of WiFi and don’t use companions in multiplayer.

Multiplayer works fine for me, though for some reason, some enemies are invisible and just destroy the other player
And there is nothing you can do about it (as the other player)
When you do get in multipla6er just wanted to warn you

That’s a known bug. Refering to the last stream the team is working on that. They mentioned that they first fixed the disappering/invisible companions.