Multiplayer not currently working - cannot join public games

As the title suggests, my multiplayer is not currently functional. Recently, I decided I would try trading stuff to get some attachments I don’t have at the moment. I am on PC (Steam), with an RTX 2060 and 16gb of RAM.
Whenever I try to join a random multiplayer game, however, after about 10 or so seconds, it comes up with the error message ‘The host you attempted to connect with is no longer present.’ I have tried this in the evening, next morning, at midday and in the afternoon, so it can’t just be an issue of there being no available games. (Note that I am in Europe, not in e.g USA or Australia). Overall, I can’t seem to find a way to fix this - I have tried verifying my files’ integrity on Steam, reinstalling the game and rebooting my PC, and I still haven’t been able to join.

I have not yet tried private servers yet, mainly as nobody I know has the game. But a couple of my friends are thinking of getting it, and I’d like to know that multiplayer works for when they buy the game.

Welcome to the forum and this has been an ongoing problem. More so since the Landfill update. You will also find that players will join in on your invite only game on a regular bases. Again, welcome to the Gen Zero forum.

Thanks for the welcome, at the moment I’m not sure whether I still have the issue as I have finally found some multiplayer games, However, I thought I’d keep this up for anybody else experiencing this issue to give them the knowledge that it is still an ongoing problem.

At one time when a host exited a game with guests in his game, all the guests would get this message. But now, when you are just trying to join a game, you will get it all the time. And it is random, for me almost every time I try to join a multiplayer game. I like joining random multiplayer games more than when friends invite me so this is very annoying for me.

I am getting the same message. No matter what I do I cannot connect to anyone’s game.