No ammo in loot boxes


#1

Playing on pc joining another player’s session. Opened well over 100 boxes and not receiving any ammo. The only ammo I’m guaranteed is the box in the police car at the start and 1-5 .32 HP rounds from runners. Also I seem to be constantly looting flashlights despite already having one.

EDIT:
This is on pc, steam
Client with 2 players total.
i7-8700k, gigabyte z370 Aorus gaming wifi, 16gb g-skill f4-3200, evga gtx 1070 SC.


Ammo loot boxes all empty
#2

My friend who joined my game as had the exact same problems. (We are playing on the Xbox One)


#3

After verifying files on steam, this is no longer an issue. On consoles i may suggest reinstalling the game


#4

i have the same problem, even after verifying files im on PC (steam)


#5

Me and my son had an issue like this. Playing on XBOX. We started a game together, after doing a few missions in the starting area. After he joined my game, we got no loot, and also none of the mission tracking worked.


#6

Got the same bug, think I got it fixed now.
Playing on PC. Verifying files on Steam didn’t help. Deleting save files and starting new game didn’t help.
I have now done a complete un-install and re-install, making sure to delete the Avalanche folder containing save files before re-insatall. Looks like it’s working but need to test co-op play and test if I can use my old save file (made a backup before un-install).

Very brute force method but if it works I’m happy.

Edit: I suspect some old files got left in when the hotfixes got applied and screwed up the game.


#7

I can confirm that i do not have this problem on Xbox One. I get an occasional loot box with completely nothing in it but seeing as the loot system in this game is randomly generated sometimes theres loot in boxes and sometimes there is not so i never really found this to be a bug. If absolutely NONE of my loot boxes had any loot in it i would confirm it to be a bug but so far in my game its usually a 50/50% chance of getting something. You either get something or you don’t


#8

So this problem came back for me, I was joining a friend who was at the start, cleared out the first house you spawn at, we got to the church and i picked up the paper on the ammo box next to the shotgun and the ammo stopped showing up in the boxes. I know there’s ammo in a box as after i open the box it is empty, but i can interact with that box like there’s loot in it. Usually you can’t re-open an empty box.


#9

Check your save file folder here “C:\Users\User\Documents\Avalanche Studios\GenerationZero\Saves”, you should have 2 folders, one with a long number and one named settings, if you have a 3rd folder your game is also bugged.
A complete re-install seems to fix it, you also need to delete the Avalanche folder in Documents before re-install, just make a backup of your save file first that is the folder with the long number, for me it seems to be working using my old save file after re-install. I haven’t tried co-op yet after I done this though.


#10

I don’t know what you are so upset about. The game gave you like 1.000.000 bullets before. it’s a survival. Finding nearly no bullets is imo a good thing. You need to plan what to attack and ambush, instead of the run and gun it was before.


#11

Having this same issue. It seems this bug only seems to affect guests in a coop game. The host gets piles of ammo just like in single player, but guests open one empty ammo box after another. This goes for ammo boxes, dead soldiers, and robots. Finding ammo in any ‘normal’ drop is rare, and when it does show up, it’s typically only .32 ACP and bird shot. Not bad if you’re just starting out, but bad if you don’t need those ammo types any more.

Two friends and I last night were in a big fight with a tank, harvester, 3 hunters and a few runners. The host was looting lots of great FMJ ammo from all the wrecks. Myself and the other guest were opening one empty wreck after another - getting nothing in most, and like 4-8 rounds of FMJ in the tank. Literally, any hunter or Tank we killed would drop lots of ammo for the host, but 4-8 rounds of good ammo for the guests. Other ammo boxes would give us nothing but the aforementioned bird shot and .32 ammo.

I also noticed there seems to be a large disparity in med kit drops between hosts and guests. Host tends to get very few medkits and adrenaline, but guests are picking up a ridiculous number of them. When I was hosting, I was using up my medkits as fast as I was getting them. I’d rarely have more than a dozen at a time. The guests in my game had multiple stacks of them by the time we finished our session.

The last couple of nights, this was reversed. I was playing as a guest in a friend’s game, and by the end of a 2 hour play session, I had 5 stacks of medkits and was tossing them to make room in my inventory.

Also, as a guest, the number of flashlights and binoculars I’m seeing in loot bags is ridiculous. This doesn’t seem to affect the game host, only the guests.


#12

Tried verifying files. Bug is still there. Tried uninstalling the game then removing the Avalanche Games forlder (while keeping my save game file), and same issue is still there.


#13

I remember everything was fine at launch for my friends who joined my game. I didn’t play for awhile after that because I wanted to play with another group that wasn’t run in gun. As of 5/15 and 5/16 whenever I was in my friends games I experience the exact same problems. Has a workaround been found for this?


#14

If you are playing co-op and loot is less common than it should be, make sure to match your weapons with the weapons of the host. This for whatever reason increases the ammount of ammo you get.

I dont know why or how, but it works.
I went from 1-2 SMG/AR ammo to 40-50 ammo in single boxes right after matching weapons.


#15

We’re running the same weapons. Not same attachments, but same weapons. No difference. I made my own bug report and someone else stated the same issue. Regardless, I shouldn’t have to match weapons with someone just to get by, it’s ridiculous.


#16

clients on my hosted game find only empty ammo crates.
(“only clients” Me as host no problem my crates always full.)
Ammunition is a big part of the game to survive the robot invasion.
we stop today playing Generation Zero because a small bug with big impact.
2. Flashlight invasion in all bags and crates. (only as client)


#17

I’ve had the empty ammo boxes problem when playing as a client while a friend ran the host, and noticed something that might help shine a light on what is going on.

It seems this has something to do with how much ammo I’m humping at the moment. For instance after emptying all 7.62mm ammunition I had (some +300 rounds) into some harvesters (the first we encountered) I suddenly started finding ammunition again. It was mostly 7.62mm but with a few in other calibres now and then. After I had built up some stock again the ammo boxes dried up.

Throwing out all birdshot for the shotgun also resulted in me getting some ammo again from the ammo boxes, but again it soon dried up.

This resulted in me throwing away all .32ACP ammo, but as before the ammo boxes soon dried up again.

I have no idea of exactly what it is that trigger this. It could be total number of shells, total number of types of ammunition or some other thing, but it does seem that packing away ammo for future use in desperate times is verboten.

Now I don’t know how much ammo my friend was humping at the time, but he never had the ammo boxes turn up empty, at least not to the degree that he noticed anything strange.

I admit that I do have a habit of hoarding all ammo I come across in games, but it’s the first time I’ve run into a game that seems to do all it can to curb this. As I already had run out of space in my backpack and had to prioritize it was already self regulating so I don’t see why they would want to do this.

I’d also like to note that I have not played GZ single player at all so I have no idea if the same thing happens there. The totally whacked up save system with shared world between characters has curbed any attempt at this. After all what good is it to try to run a new char through the game when all boxes have been looted and all weapons are gone. And I don’t want to delete my MP char just so I can do a SP run. It just doesn’t make any sense to me. If they wanted a way to transfer equipment from one char to another then the easy way would have been a shared stash like any normal game does it, but nooo…


#18

When we play on Ps4 ammo boxes are almost always empty for clients. When there is ammo it’s usually. 243 soft point.


#19

This bug is starting to get really annoying. You have to make an ammo run in your solo game first before connecting to a friend. And then in game just hope he finds enough ammo so he can give you some. Yesterday there was only ammo in a few boxes (maybe 1 out of 10) and split between 2-3 bullets of either .243 that we dont’t use or 9mm pistol. Sometimes a single .50 cal.

PS4 Pro and PS4