PC Crash - all saves lost

Did you start a new game? If not there is a chance that you can recover from Steam cloud.

Not perfectly sure how. At first I would backup the save game folder. Are the files still present on disk? If yes, they are likely corrupted. Maybe because your PC crashed during a write operation. Hopefully, the corrupted ones did not get uploaded to Steam.

C:\Users\YourUserName\Documents\Avalanche Studios\GenerationZero\Saves\SomeLongNumber

Then delete and redownload the game and then you should get your save games from the Steam cloud once you relaunch the game.

Would love others to confirm my logic, though!!

Other than that, do you do regular (daily, e.g.) backups of your C drive? Also sometimes Windows creates “previous versions” (its in the file or folder properties).

FWIW, I have the files ‘savegame’ and ‘savegame.bac’ in the above folder. AFTER the backup, remove the ‘savegame’ and then remove the file ending from the ‘.bac’ file. It should be the last available backup. Maybe that already fixes your saves.

Perform all this with game and Steam closed.

No thankfully I didn’t start a new game - but even through re-installing and trying to re-load saves that I anticipated to be saved online, I have had no luck so far. The saves are still present - I found them in the folder. I actually have an even older series of saved games stored, which I was able to successfully launch, but when I tried to place the ‘corrupted’ saves and cache back into the right folder it wouldn’t provide me with the option to ‘continue’ in the game menu.

The backup option is interesting though, so I’ll try that potentially - I’ve done that before and have had issues with loading a character save from a backup. Basically I had to create a new character, play, exit, and then load the actual character I wanted to play.

I wish you good luck though, keep us posted!

1 Like

This has happened to my son on three different occasions. The so called backup file “savegame.bac” was also corrupted, so there were no way to restore.

It made me write a batch file that continously backs up the saved game folder to three different backup folders, on a set timed interval. It runs in the background when the game plays. Hopefully this will help restore in case of another hard crash that corrupts the save file.


Good idea. I use a Windows task for creating a snapshot for that (Volume Shadow Copy). It let’s me access “Previous Versions”:

This is what “System Protection” usually does, but for some reasons Windows does not create “Previous Versions” on the C drive. So I created my own task for that:

If anyone would like to do that and needs assistance (it is a little tricky), just ask.

1 Like


Click :wink:

It makes a backup copy and then launches the game. It’s not on a timer, though.


That timer is a nice idea but did you test it and does it actually work?

I remember trying to copy a save file once whilst being, quite some time already, in the game (Borderlands 2 that was, I believe). It had saved multiple times already in-game but that just gave me a version from before the game started entirely. Not sure what that was all about but ever since I’ve not counted on copying files that are in use. :grimacing:

1 Like

I will try it out right away and post back. My bat file is made to make a backup every third minute, first to backup folder 1, three minutes later to folder 2, then folder 3 and then start over with folder 1. It only copies the file(s) if they have changed.

Will post back soon.

Just tried it by grabbing the oldest backups and replaced the actual saves, and yes it worked just fine, I was even at a different location so it was easy to check.

Ended up not doing a restore as I didn’t fancy having the same issues as last time - bit the bullet and restarted the whole thing again for the third and hopefully final time haha. Interesting to see the suggestions here though for the routine backups etc so thanks all for sharing and the suggestions!

1 Like

I’m not sure that you understand exactly what I mean (or if I explained it clearly enough, of course :slight_smile:). But just to be sure (since it would be an absolute bummer if not):

It’s entirely possible that the operating system gives you an old “shadow copy” of the save file from the moment the game starts and opened the save file.

If that’s the case then changes are only committed when the game exits. As a result, the next time you start the batch file, all 3 backup saves will have changed (according to your copy command) compared to the “new” save file.

The point is: does it make any more copies after that first 3 times? Since the game saves literally every time your inventory changes (you can force this by shuffling something around yourself; see the save icon in the top right corner), you should see 3 backup saves with different date/time stamps (“date modified”) that are from just before you exited the game (and obviously differing from each other by 3 minutes).

Of course, that means that you’d have to play for longer than 12 minutes for any confirmation on that. Or you can try a temporary batch file with a shorter interval for testing. Wait for the interval to pass and make an obvious change to the inventory. Repeat 2 more times. And then reload each backup and see if it’s actually different.

Maybe more convenient for testing is to use time stamps (see my link if you don’t know how) and just keep on adding copies in a single timer and single base folder.

This happened to me 3 times before I just started making my own backups with 7zip:
Install 7zip (freeware) and then just open your Documents folder and right-click on Avalanche Games and select ‘add to archive’ and then add a date to the archive name and your set. If your saves get borked, just delete Avalanche Games folder and restore to same location. This has saved my ass a few times since I’ve started doing it. Though thankfully I don’t have the same hard crashes like that any more.

1 Like

That is a simple, good solution. Although it requires manual interaction, which is prone to forgetting. I’d also always recommend to create backups on a different medium, at least a different ‘hard’ drive.

Just an tough. Have you disabled write back cache from your HDD, at least the one which has C: drive on it? Write-Back cache holds information that is going to be writen to HDD/SSD. And if PC hard crashes, this information might be lost. Causing loss of save data or corrupting whole save folder if game keeps those files open.

This is for Win 10 (should work on Win7 also)
To open device manager
Press WIN+R
Type: devmgmt.msc
Locate: Disk drives, expand view. Check properties and Policies tab. There is write-back cache settings.

Not a bad point. But just a disclaimer: disabling the write-back cache usually comes with a hard performance penalty. I just tested this for an m.2 PCIe SSD. I have set up a new box for a server application. I have re-enabled the write-back cache and successfully returned from the stone age.

Of course, if it was a production server, I’d go with super caps on the SSD.

Late reply, sorry.

Yes it keeps making copies throughout my entire game session. The batch files only makes copies if the save file has changed compared to the file in the backup folder.

xcopy “Saves” “backup1” /s /y /i /d
timeout /t 180 /nobreak

then onto the next one, and after all three, start over again

I’ve tested to restore the backups, and can confirm they work (easily spotted since I can be in different location on each backup, or something has changed in the inventory).

The batch files starts the game, backups and checks if GZ is still running - if not it will terminate.

Maybe you can post that one, as well? Could help other users.

It’s a mess that could be made more efficient, but it works. Place the batch file in the
Avalanche Studios\GenerationZero folder under My Documents, create a shortcut to it and use that to start the game (optional), or run it after the game has launched.

Also, I’m not really sure if the Steam ID for the game is the same for everyone, can anyone confirm?

echo off
rem Change title of CMD window
title GZ Backup utility

rem Start the game if it's not already running, wait 60 seconds before proceeding
echo Starting GZ if it's not already running...
start steam://rungameid/704270
timeout /t 60 /nobreak

rem Setting the variable 'process' = to the name of the running process
set process=GenerationZero_F.exe

rem Set a counter to keep track of rounds
set /a a=1

rem Start of the loop

rem Check to see that Generation Zero is running, otherwise end script
tasklist /FI "IMAGENAME eq %process%" | find /I "%process%" > nul
IF %ERRORLEVEL% equ 1 goto finish

rem Type which round of backup is running
echo Backup, round: %a%

rem First copy, with /t seconds delay before moving on to the next
xcopy "Saves" "backup1" /s /y /i /d
timeout /t 180 /nobreak

rem Check to see that Generation Zero is running, otherwise end script
tasklist /FI "IMAGENAME eq %process%" | find /I "%process%" > nul
IF %ERRORLEVEL% equ 1 goto finish

rem Second copy, with /t seconds delay before moving on to the next
xcopy "Saves" "backup2" /s /y /i /d
timeout /t 180 /nobreak

rem Check to see that Generation Zero is running, otherwise end script
tasklist /FI "IMAGENAME eq %process%" | find /I "%process%" > nul
IF %ERRORLEVEL% equ 1 goto finish

rem Third copy, with /t seconds delay before moving on to the next
xcopy "Saves" "backup3" /s /y /i /d
timeout /t 180 /nobreak

rem Add 1 to the counter
set /a a = %a% + 1

rem Go to the beginning of the loop
goto start

rem Game's no longer running, terminating
echo GZ is not running, terminating script...
timeout /t 10 /nobreak

Hi! my pc forezen when the game are saving in the safe house. after restart game it welcome me like a new player…

**Platform:** PC

**Steps To Reproduce:** .zip save files, than deleted folder, but no way. rename savegame, no way.. files corrupted, steam cloud files corrupted too. windows folder history are empty.. 

**Images / Videos:** 

**Host or Client:** SOLO

**Players in your game:** SOLO

**Specifications:** Acer Nitro 5, 1060 6GB, i5 8300H, 8Gb RAM, WIN10 64bit

Please help! THX

Merged threads about the same issue. I’ll also poke a dev to look at it. Feel free to look over the thread, see if anything works for you.


Seriously devs, since this is still an issue, you really need work on a better solution. You implemented the extra backup of the save file, but since this file seems to be created at the same time as the original, you really, really need to implement some sort of extra backups, with a delay between them - otherwise, what’s the point?
People shouldn’t have to resort to fixing backup scripts or whatnot. This is a MAJOR design flaw that I can’t understand is still around.

Fix it - now.

1 Like