PC Game Pass - Infinite loading screen on new game / continue

My brother is on pc. Ram into that bug last night where he couldn’t get past the infinite loading screen.
ITS BEEN FIXED. thank you so much dev and team for being so fast about it. Great job.

Still isn’t fixed for me. Only different thing is that the Multiplayer button doesn’t crash the game anymore it just doesn’t do anything… I have reinstalled the game since the fix and deleted savefile and still nothing. Any help ?

It still is not working for me either. Has region got something to do with it? I’m located in Germany.

Hey @Anduallex2 & @gameover-nl :wave:

Sorry to hear that :disappointed: Let’s try and figure out what is happening here…

First off, are you are still getting the issue just as described (infinite loading screen on new game / continue - black screen with loading icon in top right corner)? IF it is behaving differently please describe the issue step by step please.

Are you on Windows 11? If that is the case please try the workaround below;

If the issue persists, please try the following things and let me know how that goes;

  1. Restart the game
  2. Are you playing online OR offline? (IF playing offline please try to play online)
  3. Sign in and out of your user on the xbox application
  4. Restart the xbox application (close it down completely and boot it again)
  5. Restart your PC

And If the issue stops occurring please let us know in this thread what fixed it so others can benefit from it. Thank you for your time and sorry for the inconvenience! :pray:

1 Like

UPDATE: As of one minute ago, the game now launches!

I reinstalled the Xbox App, signed in and out again, and then reinstalled the game. Not sure which step helped but something worked.

I haven’t tried multiplayer yet, will update if I have connection issues.


I’m currently still experiencing the same infinite loading screen error (with the icon in the top right) on my Windows 10 PC via the Xbox Gamepass.

I’ve tried nearly all of the solutions described above, except for launching the game offline. I’m not sure if you can do with the Gamepass version.

I’ve also tried creating all sorts of different new characters and trying to continue from them, no luck.

I’m on the east coast of the USA.

Another note, when I click the multiplayer option nothing happens. Just wanted to let you know.

Bit of shame - I had no idea about this co-op shooter and my friends and we really wanted to try it out.

Update: game works, not sure if it’s something I did or the game fixed itself.
I am on Windows 10 Build 19044. I did update to version 21H1 and reinstalled the Xbox application.
I noticed that in the settings I appeared to be logged out from the Avalanche Apex Account which might have been the cause since after updating to version 21H1 I got prompted upon launching the game to create an account. After that the game worked fine. Anyways, thank you for your hard work. :pray:

Fantastic to hear it’s working for people now. We’ll keep the threads running if more want to chime in and confirm this. Then we can tag this issue as solved :slightly_smiling_face:

1 Like

Hi guys!
I apologize for my English, I use a translator.
The problem with the black screen is solved. But! I have terrible lags while in the main menu. The game freezes every 3 seconds. CPU load is 100%. There were no such problems before. I changed the game settings from ultra to the minimum, there are no changes. I use game pass. (i5 8500+2060 Rog stix+16GB). The game is installed on the ssd. All drivers are updated. Help solve the problem.

Good to go! Loaded right up without having to go into offline mode or change anything on my end. Thanks for the updates and explanations :smiley:

I have a question that’s somewhat related as it’s a gamepass question, does Generation Zero utilize Xbox’s Teredo network for multiplayer or cross-play? I realized yesterday it was off by default in gpedit and turned it on for some of my other games but it’d be reassuring to know whether or not it’s used here.

This issue is still occurring for me.

I am on the gamepass version for pc on windows 10. I was unable to play offline as the game requires me to sign in to xbox.

1 Like

Hey @kabardosRUS :wave:

Good to hear that it’s working for you. Regarding the lag / poor performance, please make a separate bug topic for that and we can look at that separately in a dedicated thread. Thanks!

Hey @ManbeastRagewar :wave:

Sorry to hear that. Let’s see if we can figure out what is going on!

The issue is still occurring exactly as described? Infinite loading screen (with blinking save icon in top right corner) after new game / continue? Or is it occurring somewhere else or in a slightly different manner? Asking just in case we have a different variant or issue on our hands as theoretically this particular issue should no longer occur… :thinking:

Could it be the issue below that your are experiencing by any chance? (Seems to be a high resolution / layout scale issue, see potential workaround in that topic)


Have you tried the things below?

Also make sure that you have the latest windows updates, graphics card drivers, etc as stuff like that can sometimes cause issues.

Please let me know how that goes and if the issue persists! Sorry for the inconvenience :pray:

I had tried everything except signing out and back into my xbox application, which just fixed it. I don’t understand why restarting my PC didn’t help if signing out did, but whatever, its working now. :joy:

Thank you!

Yeah that’s pretty peculiar, but good to hear! \o/ thanks for the update!

Still not working for me.

Still the same issue as this:

Installed in Xbox App, start the game, sign-in, do a character creation, click start and I’m looking at an infinite loading screen. Black screen with the auto-save icon blinking.
Mouse is moving, I also see CPU load, and GPU load. But nothing happens.
Quit with ALT-F4, get a “Continue Game” option after restarting the game, but that also is loading forever.
New character creation does not help, same problem.
System specs:
OS: Windows 10 Pro 21H2, latest updates installed. (Build 19044.1387)
Hardware: Gefore GTX1080 with 496.76 drivers, Core i5-8600K, 16GB memory.
Repairing and resetting the Xbox App also does not make a difference. Xbox App up to date.

I reset the Xbox App again, no difference. Nvidia driver updates to version 497.09.

Other variables that may be of influence:
Dual-screen setup
Geforce Experience installed
Located in Germany

Offline mode not possible, I need to sign in with my Xbox Account in order to play.


Hmm, signing in and out of the Xbox App did the trick for me. Funny that a reset of the App doesn’t work, but signing in and out does. Well, whatever, it works now!

Thanks. :slight_smile:

Having the same issues. I had an old game from a long time ago when playing on a beta account. Just wanted to see what’s going on in the game before starting again.

Clicked the game, it continually had the loading symbol in the top right.
Tried to create a new character, symbol again continually loading in the top right.
I also need to sign into my XBox account every single time I load the game.

I’ve loaded the game, connected my account, and quit to see if it would stick, it didn’t.

Not sure what to do.

Haye you tried signing out and in again in the Xbox App itself? That worked for me.

1 Like

Lol I can’t believe that’s what fixed it for me. Thank you :man_facepalming:

Hey @SecretEnding :wave:

Have you tried the suggested workarounds? The signing in and out on the XBOX application seems to solve it for some people, so if you haven’t already please try that and if that doesn’t sort it out try the other workarounds and let us know how that goes! :crossed_fingers:

Platform: PC Game pass

Description: I still have the infinite loading screen and cant access multiplayer… what do i need to do to resolve. Ive already spent too much time trying to figure it out.

Steps To Reproduce: did the updates, reboots, logging out, etc.