PC Game Pass - Unable to play multiplayer, offline message, "host not present" message on trying to join friend

I bought gen z a day ago played single player for awhile like 3 hours. I wanted to see what multiplayer was like so I paused the game and it said I should go to the main menu and start a new session. I clicked on multiplayer and the clicked find game it started looking for a game but I sat there for ten minutes and it was still looking for a game. so I stopped and went back to single player and tried again and it did the same thing. I tried deleting and redownloading the game and it was having the same problem so i went and played a different game. is there a way to fix this?

Hey @bomberman1234566 :wave:

Let’s see if we can figure this out…

It sounds like you may be experiencing a case of the issue below;

Is that correct? You are getting the “invalid game session” message on trying to access the multiplayer menu after having started a session via “continue” or “new game”? If that is the case it should be fixed by now (for more info see the linked post below) BUT we have seen that some users in some cases have to sign out of the xbox application and then sign back in again for some of these issues to stop occurring.

Please try the potential workaround and let us know how that goes.

Sorry for the inconvenience and thanks for reporting! :pray:

so it doesn’t give me an error message at all it just can’t find a game. when it try to join multiplayer in single player it says that I am offline and I have to go to the main menu and start a new session. if I try to join my friend it says the the host doesn’t exist. everything loads perfectly fine and i am having no other problems I think the game is great. but I can’t connect to multiplayer

i have been looking at the forum for awhile to see if anybody has had the same problem. I have already looked at those forums and tried the solutions you had and it didn’t work.

Ah, I see. Thanks for the additional information. Much appreciated!

Before you try any of the things below have you checked if there are any windows updates available for your PC or XBOX application? Could be worth checking because that has fixed issues for people on some occasions, so definitely worth checking that before trying anything more advanced / complicated.

It seems you have tried joining your friend and others, but what happens when your friend tries to join you after you have hosted a session via continue / new game? Do they get an error message? If so which message do they get?

Please note that in order for you or your friends session to be joinable you need to make sure that the ‘WHO CAN JOIN’-setting in the pause multiplayer menu (after having hosted via ‘CONTINUE’ or ‘NEW GAME’) isn’t set to ‘INVITE ONLY’.

What type of network are you on? Could you by any chance try signing in and playing on a different PC, and also if possible try playing on a different network just to see if it behaves differently? There has been indications that GenZ might have problems with certain types of networks, e.g. college campus networks, etc.

You mentioned you’ve been searching the forum, so maybe you’ll already seen these but I’ll throw in some links here below just in case those were missed;

Could it be that you are experiencing this issue…

OR possibly this issue…

…Does any of these two linked topics above (reading the title and reports of other users) describe the issue, behavior and error messages that you are seeing?

If it seems to be any of the issues above it would be unfortunate because those issues are fairly uncommon and not that much is known about them, why they occur or what to do about them. There are some workarounds and things that have fixed it for some, but not all. We have tickets for tracking and investigating those two similar, but slightly different, issues, and although we have some clues we have yet to identify the issue and haven’t committed any fixes for them at this time.

If you try any of these suggestions / workaround please let us know how it goes!

Sorry for the inconvenience and thank you for you patience :pray:

Are you by any chance on VPN? IF that is the case could you try disabling the VPN and see if the issue still occurs?

Platform : PC
Description: Even though I have an internet connection, I cannot join or invite friends to game, Says host is not present when I am invited, and if I try to host a game it says I need to set my game to be able to be joined, which I cant even access the menu to change any multiplayer options.

Steps to reproduce: Try to play with my friends, AT ALL

Merged with existing report.


Hey @aeternyth :wave:

Regarding the above, could you take a screenshot of the message you get when you try to host and share it in this topic? What happens when you try to access the multiplayer menu from the “pause menu”? Is there another message then? IF so please also provide a screenshot of that. Thanks!

Before you try the things further down, are you sure that you have the latest updates for your PC, Windows, XBOX application, etc? Please check that and make sure that you have the latest updates for Windows (And IF playing via the XBOX application on PC also check that the application is updated).

If that didn’t help, below are some other things to test;

Let us know if any of these things helped, or if the issue persists.

Sorry for the inconvenience and thank you for your patience! :pray:

1 Like

Platform: Windows 10, Steam
Description: I’ve had this for two (nope three - scratch that, four) days straight now. Any time I try to find a game it first says “Finding game”, “Connecting to host” and finally “The host that you attempted to connect with is no longer present.”
Steps checked and taken:

  • Windows up to date.
  • Game worked fine when a player connected to a game I hosted.
  • Settings always on Anyone can join but irrelevant when i try to join others.
  • Network is just bog standard domestic internet connection.
  • No VPN.
  • Have done several reboots.
  • Refreshed DHCP.
  • Cleared DNS Cache.
  • Saves backed up, game uninstalled and reinstalled, saves restored.
  • Managed to join one game which disconnected after about 30 minutes.
  • Same issue occurring again.
    CPU: Intel Xenon E5-1620 v3
    RAM: 32 GB
    GPU: NVIDIA GeForce GTX 1060 6GB
    O/S: Windows 10 Pro 21H2
    N/W: Cable 350MB/s

And suddenly it just resolves itself. Aint computers great.

Next day and the issue is back. Twenty minutes so far of the same issue :frowning:
Could this issue be caused by the lobby being very slow at updating hosting sessions? Perhaps there is an issue that hosting sessions are not refreshed often enough or quickly enough. Does the service have a long polling interval or something?

The game worked ok again last night after I played a session solo for about an hour. On my next try to connect to a multiplayer game I connected almost instantly. So I had another thought. When playing on a PC on the Steam platform, presumably there is an interaction with Steam when we search for a multiplayer game. Could there be certain conditions when there is a delay between starting the game and the game (lobby or whatever) synchronizes with Steam?
Tonight the error message is different, Tonight it says “Your connection attempt to the multiplayer session has timed out.”

1 Like

I feel there is something more that changed.
Maybe it’s related to the update and the change that you now need to be connected to apex in order to play. There are probably some checks that run into loops, timeouts or crashes.

Im not playing on pc or with a xbox version, but on ps5. There my buddy and me have the problem, that we can’t follow an invitation from within our own games. It will lead into a crash or at least a disconnect due to a timeout. Then we have to quit the game, accept the invitation in the playstation menu and the game starts. Most times it will follow a crash or timeout again. The next try always was succesful until now.

Happens since base assault update and the mentioned duty to be connected to apex.

Addendum to my previous post. There seems to be some sort of synchronization issue. Today I had a series of oddities that might give some hint to what the issue is. Unfortunately I couldn’t reproduce them and it happened too fast for a screenshot.
I selected Multiplayer and clicked Find Game.
My client found a game and joined it.
Three players were already in the game according to the chatbox that came up before I had spawned into the map.
Within a couple of seconds I got the message that I had been disconnected from the multiplayer session and was left with the menu again.
Another couple of seconds and the screen went black and then I was spawned into the game with the message “Connecting to host”.
I was then returned to the menu with another message saying theat my connection attempt had timed out.
Subsequent attempts to join results in alternating sequences of
“Finding Game” → “Connecting to host” → “The host you are trying to connect to is no longer present” and
“Finding Game” → “Connecting to host” → “Your connection attempt to the multiplayer session has timed out”
I have no problem hosting games.