PC Game Pass - Infinite loading screen on new game / continue

Yes, it seems you are unable to “offline” run the game because as soon as you load it up it asks you to log into your xbox live account, it seems even with “offline permissions” enabled it fails at logging into your account on startup unless its plugged into a network, even loading up the game, then quit xbox live it still asks to log in or, if you log in first then quit xbox live, it logs you out in game almost instantly and throws you back to the log in screen in the game. Could this be due to the fact the game runs in multiplayer by default?

I’ve pinned the support thread about this issue. Please keep posts about this issue here, instead of creating new threads.


1 Like

I have same problem with Infinite loading screen & cant play
Im on Win10

Alright! Not sure if you guys fixed the issue…but I think I found a WORKAROUND!*

In the Xbox app, if you go open Generation Zero under “Cloud Gaming” and run the game, maybe walk a couple feet and then exit out the game.

If you open Generation Zero (the one installed on your PC) and then click continue, you shouldn’t have any issues.

Letme know if this helped! :smiley:

Hello again :wave:

:information_source: Some more details and context on the issues we’ve been seeing on XBOX / PC / GAME PASS:

As mentioned previously, we’ve zeroed in on the issue that is causing a variety of issues to occur. With the new backend system we implemented to enable cross play, we hit our player limit. This caused those who we’re playing past that concurrent player limit to crash. We’ve investigated this with our service provider and found the solution to open it up to an unlimited player count. This should put an end to the multiplayer crashes that most are seeing. Note that there might be a bit of a delay for the change to come in effect. If there are continuing issues, we do ask that you get in touch with our support channels.

Thank you for your patience :pray:

1 Like

Yess the game start working thanks bro

1 Like

I have a solution!
As people have said, you have to play Generation Zero in Offline mode in order to play
You ma be wondering how you could play offline when Xbox Gamepass games require you to be online to sign in to your profile when booting up the game? Well here’s the detailed step-by-step solution:

  • Make sure your computer is up to date by opening settings, Update & Security and checking your Windows Update section to see if there’s a pending update. If so, complete the update (you may need to restart your computer to complete the update).

  • Open up your Microsoft Store, click on your Microsoft Profile and go to App Settings. Look for the option called Offline Permisions and make sure it’s on:

  • To be safe, open up your Xbox Gamepass app and click on your profile, open settings and click on the general tab. Under Offline Permissions, make sure the box is ticked:

You should now be ready to begin the boot-up process.

  • Disconnect from the internet via the wifi settings (I do not use ethernet, so if there is no option to disconnect from an ethernet connection through your computer, you may need to just unplug it for the time being)

  • Open the game through the Gamepass app, it should appear to boot up just like it usually would

  • Once the profile sign-in window appears, it should display a blank profile picture with the option to switch accounts or sign in/something along those lines. Now is the time to reconnect your internet connection

  • Once you are reconnected to the internet, attempt to sign in. You may have to attempt to sign in while offline as I did before signing in while online.

  • The menu should now appear and look exactly the same. I created a new character but clicking continue if you already have a character should work too.

My theory as to why this works as the game boots in ‘Offline Mode’, but once it starts in such a mode it will remain like that, whether or not there’s an internet connection. I haven’t tested multiplayer, but I presume it is unavailable. You’re free to test that out though, I just don’t have anyone to do so :+1:

I hope this works as it did for me and hopefully it’s sufficiently comprehensible. Good luck out there, 80’s kids!

1 Like

There is literally no reason to do this now. The issue has been fixed.

:information_source: As mentioned by @TheReaper15a, this issue should now be fixed and no longer be occur!

(However, IF anyone is still experiencing this issue feel free to post in this topic and @ me)


Yes it appears that all problems are fixed for me now. Thank you so much for yours and your teams hard work fixing these issues. Can’t wait to dive in and try this game out!

1 Like

Im still having Inf. Load Screen :frowning:

yes i can confirm that it works !!! thank you soooooooooo much Guys for fixing this issue :v:t4: :fire:

Do you still get it if you restart the game and try again now one hour later?

1 Like

Thanks bro, Its Working now :+1:

My brother is on pc. Ram into that bug last night where he couldn’t get past the infinite loading screen.
ITS BEEN FIXED. thank you so much dev and team for being so fast about it. Great job.

Still isn’t fixed for me. Only different thing is that the Multiplayer button doesn’t crash the game anymore it just doesn’t do anything… I have reinstalled the game since the fix and deleted savefile and still nothing. Any help ?

It still is not working for me either. Has region got something to do with it? I’m located in Germany.

Hey @Anduallex2 & @gameover-nl :wave:

Sorry to hear that :disappointed: Let’s try and figure out what is happening here…

First off, are you are still getting the issue just as described (infinite loading screen on new game / continue - black screen with loading icon in top right corner)? IF it is behaving differently please describe the issue step by step please.

Are you on Windows 11? If that is the case please try the workaround below;

If the issue persists, please try the following things and let me know how that goes;

  1. Restart the game
  2. Are you playing online OR offline? (IF playing offline please try to play online)
  3. Sign in and out of your user on the xbox application
  4. Restart the xbox application (close it down completely and boot it again)
  5. Restart your PC

And If the issue stops occurring please let us know in this thread what fixed it so others can benefit from it. Thank you for your time and sorry for the inconvenience! :pray:

1 Like

UPDATE: As of one minute ago, the game now launches!

I reinstalled the Xbox App, signed in and out again, and then reinstalled the game. Not sure which step helped but something worked.

I haven’t tried multiplayer yet, will update if I have connection issues.


I’m currently still experiencing the same infinite loading screen error (with the icon in the top right) on my Windows 10 PC via the Xbox Gamepass.

I’ve tried nearly all of the solutions described above, except for launching the game offline. I’m not sure if you can do with the Gamepass version.

I’ve also tried creating all sorts of different new characters and trying to continue from them, no luck.

I’m on the east coast of the USA.

Another note, when I click the multiplayer option nothing happens. Just wanted to let you know.

Bit of shame - I had no idea about this co-op shooter and my friends and we really wanted to try it out.