Xbox Game Pass - Invalid Game Session on trying to play multiplayer

Merged threads covering the same issue.


im getting the same issue for Series S

While in game, it says match is invalid. When trying to find a match it crashes instantly everytime.

Merged threads. Please search before you create a report, the topic is active.


Having an identical issue on my Series X. Am entirely unable to host an online session (I have fiber optic internet, wired to my console) and the game instantly crashes any time I press Find Game in the Multiplayer tab

I am having the Same issue on my Series X.

Link to my bug report:

Same thing here i’ve even tried reinstalling the game and deleting save data

I’ve pinned the support thread about this issue. Please keep posts about this issue here, instead of creating new threads.


Hello everyone :wave:

The “invalid game session” issue is caused by the same root issue that is also causing the issues below;

The issue has been identified and we are working on getting it sorted asap!

Sorry for the inconvenience and thank you for your patience :pray:


See the post below for some more context/info on the issues we are seeing right now;

:information_source: This issue should now be fixed and no longer be occur!

(However, IF anyone is still experiencing this issue feel free to post in this topic and @ me)

Thanks again for your patience while we worked on sorting this out! :pray:

1 Like

Have you tried streaming the game from the cloud. I had similar issues then I deleted the game and started streaming. No major issues since.

it’s not fixed.

gamepass pc:

I’ve been away from this great game for many months now because of this issue. I keep hoping to come back to this thread and find a fix for this. My sad lvl 51 player will just need to play a local game from now on I guess. Sadness.

Apologies for my last message, let me answer your questions first. I work in IT and know the frustrations of working with us “end users”

I’m on a PC version of the game purchased from the MS Store. Patching is up to date. I can launch the game fine, play offline fine, no issues. I get the invalid game session whenever i try to go multi-player from within the game with my character loaded.

Please try the following things and let me know how that goes;

  1. Restart the game - Tried that
  2. Are you playing online OR offline? (IF playing offline please try to play online) Online
  3. Sign in and out of your user on the xbox application - Tried that
  4. Restart the xbox application (close it down completely and boot it again) Tried that, have not completely removed/re-added.
  5. Restart your PC - Tried that.

If this helps, i get the error in this screenshot, when i try to “find a game” from off the main menu.

This topic is over a year old. Knivspark for example has moved on from QA and will probably not answer if you reply to his old posts. Keep that in mind when posting in old topics.


This is still an issue and just happened to me and my wife today. Loaded up our saved world that we’ve been playing on for weeks, clicked on multiplayer and it gave both of us the invalid game session message saying we are stuck in offline mode.

Just happened to me as well its insane this issue is still persisting after years of this being known about.

No, it’s new again with the recent update.