Potential performance degradation since 1.03 patch?

I’m not sure this is necessarily a bug (yet) so asking here instead of the Bug Report category.

Since the last big patch, I’ve noticed a performance degradation in my game, and wondered if anyone else did as well.

My system specs:

  • Ryzen 2700x (locked at 4.2 GHz)
  • RTX 2080
  • 32GB PC3400 ( 2 x 16GB)
  • 1 TB Samsung 970 EVO
  • LG 4k FreeSync monitor
  • Windows 10 Pro

When I first got the Gen Zero on launch day, I wanted to determine what kind of frame rates I was getting to determine optimal graphical settings to use. I found I was able to easily run with maxed out detail at 4k and maintain a 65-ish fps average frame rate with the occasional dip into the 50s when action got heavy. Due to FreeSync, those dips were really unperceivable. And it seemed to run fine for the first couple of weeks.

The last week of playing (since the big April patch), I’ve been noticing some stutters and more jerkiness that wasn’t there before. Last night I decided to turn my frame rate counter back on to see what was going on, and much to my surprise my baseline frame rate seemed to be in the low 50s instead of its usual mid 60s, with dips down into the 40s. I fired up MSI Afterburner and applied an overclock to my GPU. Frame rates only marginally increased by a few fps.

Of course, lowering graphical detail at 4K boosts my frame rate back up to acceptable levels, but since I was able to play it at max before, I’d like to continue. The game is just THAT gorgeous.

I’m trying to determine if anyone else is experiencing this performance decrease since last patch. I’m trying to determine if this is something with the game, or perhaps something on my end. I haven’t seen any frame rate issues with other games I’m playing. Only Gen Zero seems to be affected. And I can’t think of anything that was changed on my system.

Any input would be appreciated.

fr : Salut, je suis français alors désolé pour mon langage. J’ai vu dans l’actualité que nvidia reconnais un bug avec les derniers drivers qui utilise trop le cpu.
un fix sera mis en place

en (google translator) : Hi, I’m French so sorry for my language. I saw in the news that nvidia recognizes a bug with the latest drivers that uses too much CPU. a fix will be put in place

Pas besoin de t’excuser pour ton language. Je suis canadien (québecois d’origine) et je suis bilingue. Mon francais écrit n’est pas du même calibre que mon français orale ou mon anglais parce-que je manque de pratique, mais je me débrouille quand-même assez bien.

Je vais assayer de télécharger ne nouveau driver nVidia ce soir pour voir si c’est le problem. Merci pour l’information.

So as @McStef62 suggested above, the nVidia driver could have been the issue. I updated to the latest and greatest nVidia driver and I’m seeing no noticeable difference.

I read up on it and details stated that the bad driver could cause it to use too much CPU. I ran the game before updating while keeping my performance tab on my task manager on my second monitor. CPU use didn’t seem to be anything crazy.

So I tried updating the driver. My game is still running at sub-50 fps level when at the same settings it was in the 60s before the last big patch. CPU usage doesn’t seem to have been affected at all by the updated driver.

So I guess my initial question still stands. Has anyone else noticed performance degradation since the 1.03 patch?