RLG-7 cannot attach vision modules after 1.36 patch

PS4 Pro, single player. After patch 1.36 cannot attach any vision modules on RLG-7. I have a 4-star x2.7 optical sight. Reboot of the game did not help. Tried different approaches (I tried to remove all attachments, put the weapon in a box, pick it up at another location, reassign the attachments etc). Nothing helps. When I trying to attach a vision module (e.g. IR), I am able to select it and even hear the sound of successful assignment, but the vision module’s field stays EMPTY, and nothing changes with RGL-7.

I even didn’t know that it’s possible to attach vision modules on it.
At least I never was able to select some.

I’ll test it again.

Maybe they dropped the feature (accidently?) when deactivating it for the bow?


I used it all the time :slight_smile: For me IR module on RLG-7 was extremely useful. This is definitely a bug, since the field for choosing a module is still active.

Confirmed, exactly like you said.
Tried it with a 5c RLG and 5c scope with a full vision module.

I play on PC. I keep losing my Full Vision Module. Seems like I was able to attach one a couple times but today it’s as you describe. It appears to add it, but the attachment stays empty. I had noticed over the last year that my scope would disappear, which is hilarious as the module was attached to nothing (always in the middle of a fight!). But, I was always able to put the scope back on. Maybe they were trying to fix that bug and accidentally introduced a new one. Anyway, I miss having a Vision Module on my RLG-7. Strange that I only see this problem one month after you encountered it.

Hmm… oookay, that’s an odd behaviour and I’m glad that I didn’t touch the attached vision module.