Steam UI change broke inviting friends

i got Generation 0 for my friend (as someone whos lvld-19 before) and wished to start over from the beginning

i havent co oped before, the settings to do so are anyone or invite only
neither works

we have researched and saw no articles as of the recent times ***

he cant invite me no matter what
i can invite him only if my game is set to anyone

neither of us can join in session
anyone else can join our game if set to anyone

uninstalling DLCs,
making new and trying old saves and worlds
progressing through the main quest
firewalls and hamachi

the furthest we got is when i invite him, he clicks to join through steam overlay, the invite disapears and does nothing,

***** we suspect that the new steam UI change screwed with the invite menu in how it works and therefore we cannot join as per usual,

I joined my friends game just last week since he hadn’t yet done the mission “Death from Above”. I wanted to test if I could get the Soviet beacons back to spawn in again, because it was great when they respawned before the update. But it did not work, when I got back to my own game beacons were still gone.

But the invite worked. He invited me via menu/multitplayer / R (invite). And I got a notification window to accept the invite, and I joined with no problems. We were both set to “Invite only”.
We did had to make sure that we were set to ‘online’.

steam online

not sure about yours but we did spend over 70 minutes ingame fluctuating between trying to join and progressing for troubleshooting

i can garuntee that we,ve tried to do so

Hi there screaminediot, and welcome to the forums!

This sounds to me like it could be network issues…
Im not saying that it IS, just that it sounds like that to me, and i have no official role here on the forum. :slight_smile:

I would test the uplink (internet connection) on both computers, making sure to check bandwidth (transfer speeds in both directions) and latency (message reply lag) with a network tester (like speedtest.net).
A websearch gave me the following numbers for comparison, apparently this is “minimum requirements” in general, and not specific to Generation Zero.
For FPS-games: 30 Mbps (Down) 1 Mbps (Up) 15 ms (latency)

For the host, the 1 Mbps (Up) speed seems quite low and may not be sufficient.

This could, at least in theory, also be a NAT/firewall-issue, or even one of your ISP´s not allowing incoming traffic or a specific port range or whatnot.
But that seems to me a bit unlikely as it would probably cause more obvious failures than the ones you describe and steam is supposed to handle those network types too.

I have had some issues connecting to some players over the years, often i could host the game and have my friends connect to me (my uplink is quite good), but we could rarely connect to a few individuals (dsl uplinks and from another part of the world), they had to connect to us for MP to work.
My son´s “gaming”-rig (at the time) was severely underpowered, but on the same uplink as me, and his hosted sessions were rarely stable but we could connect, most of the time…

The most logical conclusion is that hosting players with weak uplink cant output enough data to all the clients in time, creating odd sync errors, players not able to see each other and so on.
Or if the link is really bad, not able to even create the MP-connection between host and client(s).

What kind of uplink are you folks using?

And as this can apparently happen to underpowered computers too, then it seems reasonable to ask you, are the computer specs meeting minimum requirements?

For reference:
PC Minimum Requirements:

OS: 64bit - Windows 7 Service Pack 1

Processor: Intel i5 Quad Core

Memory: 8 GB RAM

Graphics: nVidia GTX 660 / ATI HD7870 - 2 GB VRAM / Intel Iris Pro Graphics 580

Storage: 35 GB available space

PC Recommended Specs:

OS: 64bit - Windows 10

Processor: Intel i7 Quad Core

Memory: 16 GB RAM

Graphics: nVidia GTX 960 / R9 280 - 4 GB VRAM

Storage: 35 GB available space

Did you post in the wrong topic?
It’s not about connection issues, but about not being able to invite a friend, possibly due to steam ui changes.

I would have checked the game versions first, but steam clearly shows it if there is an update…

Maybe there are any mods installed on one persons side that block it?

Idk

1 Like

Mate, its broken, please at least try (test) out what the users are telling you…
Steam has released a new UI and since then the ‘R’ for inviting friends (called “invite only” within Gen0) is broken - there is even a BIG FAT ERROR message in the Steam overlay you would have seen if you had tried instead of talking about network issues “Error Reference: Shared SteamUI_8145392_070fa3fb72d6e983 e.sort is not a function”.
There is a not obvious work-around - you need to set to allow everyone to join - then go into the steam overlay - which now allows to invite your friends from your friends list - then switch back inside Gen0 to “invite only” so no other people can join you. Important - inviting from within steam only enables “Invite to Game” if Gen0 is set to open for everyone… if it is set to “invite only” the menu option will not appear in Steam. Cheerio…

1 Like

replying cause we still wanna play the game together, tbh, i was hoping someone from Gen 0 was going to say Yae or Nae on it by now,

i,ve read the (2 ) patch notes since then and checked back here but no response

after 20 days i have now made this a copy pasta in steam

[i was hoping posting on their website was going to be more fruitful and quicker then i went into out of sight out of mind and played other games till the calendar date]

For a serious quick reply from the team the forum maybe is the wrong place.

Try to use the Generation Zero support page https://support.generationzero.com/hc/en-us or join GZs discord channel to contact the team.

Btw, which patch notes? There was no greater official update in the last 20 days, just a small hotfix for steam and xbox versions regarding one bug.

The next feature-update will be on 18th July, but I’m sure that it isn’t intended to fix YOUR issue.