Stuck with progression


#1

Hi, I’m currently totally stuck and cant progress further. I’ve finished ‘a wrench in the works’ but now have no more missions to do.
I know I’m missing ‘enemy of my enemy’ but its failed to start. I’ve done all bunker and tick jammer/radio missions also. Anyone have any idea how I can fix this? I’m about to delete and re-start, which sucks as I’ve done it all solo. Please help. Anyone??


#2

Which platform are u playing on (Xbox One, PC or PS4)?


#3

Xbox one. Its driving me nuts. Been trying to fix it all day.


#4

Have you tried joining some else game and tried to complete the mission? Other than that I don’t know what else to try.

I know that the achievement should pop once the mission is done weather it was done in solo play or multi-play.

If u want u can join my game and we can rush through the main mission. I’m also on xbox one and recently started a fresh save primarily for the It’s the Final Countdown achievement.


#5

Hey thanks it’s a kind offer, but I’m gonna just start again anyway. Sad times. Hit me up if you want to blow stuff up my GT is Natsanwa :+1:


#6

Ok, you are free to send me a message and my GT is Radiant Flames.


#7

Have you tried deleting your character and starting all over? Seems that’s your only option that works for this game. Forewarning though, might still glitch again.


#8

I deleted my lvl 28 character last night. Running through it again and hoping for the best. I really like the game and its potential, but if it messes up again I wont make another. Fingers crossed!