Thousands of items keep disappearing

This the third time now (Twice in the last 2 days) and Thousands of items, including experimental weapons, just keep disappearing.

I’m not sure if it’s from recycling, travelling or whatever. I’m just playing and then when I go to my inventory, things are gone.

This time, I just finished a medium base defend mission, recycled some items, loaded stuff I didn’t need into my storage. While organizing my load out, I went to add health packs to my medic station. Added the packs and items were gone.

The time before that, I was fighting 2 named by the Angeras church. Went to my storage box and lost most of my experimental weapons, equipment and attachments.

The first time this happened, I tried re-logging and even a fresh install. 2nd and third time, tried re-logging.

I really love this game and the potential it has, but having to constantly reacquire hard earned rare items is frustrating and disheartening.

1st time = Just after the glow in the dark dlc arrived. The visuals did not update when selecting and had to press up or down on left stick each time to make it work.

2nd time = Dec 10, approx 2200 MST. Items disappeared when using storage box at Angura’s Church.

3rd time = Dec 12, approx 2200 MST again. Tveberga Control point. Sometime between storage box and replenishing my medic centre.

I really hope you can fix this and get all my items back.

Xbox Series X
Solo, World 1, Char 1.
All dlc except the 3 wheeled one.

I believe there is some bug related to weapons augmentation fast travel and base defense/assault missions.

I just did one base defense mission
Fast traveled after, and attachments from 3 weapons disappeared and almost all of my ammo and equipment disappeared from my Inventory, only the ammo type active in each weapon survived, all the others vanished.
3 of the weapons disappeared from inventory and i could find them back in the Plundra but without any mods or attachments, the missing attachments and ammo however could not be found.