Unable to play multiplayer with friend - "Failure To Join - Host Is No Longer Present" error message shown

Our NAT types both are open as well and we are both on the Xbox platform

We bought this game with high hopes for the coop experience and it has yet to deliver y’all have created a very amazing beautiful and fin game here but sadly it is quite quickly losing its charm due to this issue it’s fun single player but the whole point was sharing the world together and until this problem is resolved I cannot on good conscious recommend to any of my friends without fear of them having the same problem I have 2 friends that are willing and wanting to purchase to play with my brother and I but I have since told them to look elsewhere since I can’t even play with one person let alone 3 others not will I have them spend money on a broken experience

Hey @SoHLunchBox :wave:

Thanks for the additional info, I’ll note this down and add it to the ticket we have for tracking this issue.

Reading your comments, and the fact that you could play together on the first day, and then the second day and onward get the same error message as @MrRoboto and being unable to play together on your network makes me think the issue probably lies elsewhere than the network, and that we should look at other aspects of the game. The fact that you just like MrRoboto can play other multiplayer games just fine further convinces me that there’s something else going on here.

Also, you getting the black screen on continue after failing to join your brother’s session and being forced to restart the game is interesting… we’ve seen similar issues before and I’ll dig up some information on that to see if there’s anything we can learn from it in regards to this issue (not being able to play with friend/specific user).

Some things worth trying out (some of these I imagine you’ve probably already tried):

  • Switch roles (host/client) and have your friend host and you join, and vice versa
  • You can’t play together with your friend, but can you connect to another befriended profile’s specific session / or can they join you? (e.g. if you have another friend who also owns GenZ who can try hosting/joining and see if either you or your friend can join them and be joined by them while hosting)
  • Similar to the thing above - Can you play with your friend using another xbox profile with xbox live which has different save data?
  • Try playing on another network
  • This is not ideal and I understand if this is not something you want to try - How much play time do you have on your save data? I imagine that at least you and your brother, @SoHLunchBox, might not have too much progress/play time since you only played for one day before this issue started occurring? I’m asking since I wonder if one of you would be willing to try and delete ALL your save data from Generation Zero (from both console + cloud via manage game) then start a fresh save to see if the issue stops occurring. If it stops occurring that would tell us that the issue lies within the save data. I totally get if this is something you wouldn’t want to do, and there is no guarantee that it’ll work so ONLY do it of your own free will (and IF you end up trying it please let us know in the comments how it went).

If you end up trying any of the things mentioned above please let me know in the comments what results you get.

Sorry for the inconvenience and thank you for your patience while we do our best to figure this out! :pray:

Hey @MrRoboto :coffee:

I’m curious, do you also get the “infinite black screen” (mentioned by @SoHLunchBox) on selecting “continue” AFTER you have failed matchmaking and getting the error message when trying to join your friend?

EDIT: I edited the topic title somewhat hoping that maybe more people will find it via search terms.

So me and my friend are on Xbox and have been playing just fine up until last night. Now it says “Failed go join host as they are no longer in the session”. But either of us would be in our own game just fine. If i join a Multiplayer session it works briefly, but that’s it. We can’t join each other.

Same issue topics merged.

//Mod

I do not. My game works fine after that, though it does sometimes crash or do that for my partner.

Noted, thanks for the info @MrRoboto! :pray:

We are not sure yet what is causing this to occur, but we have gotten similar reports now from PS4 users as well, and they aren’t on the same patch as you XBOX users.

On PS4 the “failure to join” error message is not shown and instead they get stuck on “connecting to host” when trying to connect. Other than that difference the PS4 users report the same end result, not being able to connect and play with a friend, but being able to matchmake into random sessions via “find game”.

IF anyone else is experiencing this issue on any platform, please consider sharing your information here in as much detail as possible as it’ll help our investigation of this issue.

Any updates to the issue? Is this one of the issues planned to be included in the patch talked about on October 2?

Hi @MrRoboto :wave:

We do not have anything new to report for this particular issue right now and I can’t confirm a time estimate or specific patch for a fix at this time, but we are aware of the issue and we’ll dig into it as soon as possible.

Thank you for your patience and sorry for the inconvenience :pray:

Sorry to ask again but will there be a fix for the “You are Offline” bug?
Was amazed Today was a 13Gb Patch 7.11.2020
I download it installed it accept all again and hope for the best to play online again after 6 Month.
But it still says im in OFFLINE MODE and after 4 Minutes the game just CTD?
I can play EVERY OTHER GAME with very low latency(1-4ms) and ultra High FPS (240FPS Display max) except this one.
I also setup Windows 10 and everything.
Would be very nice if there are any ideas or help

Thx in regards
Enig

1 Like

Hey @AngryGamer :wave:

I just replied to another user experiencing that issue (Stuck In Offline Mode), please see my response there:

https://forum.generationzero.com/t/stuck-in-offline-mode-trying-to-access-multiplayer-results-in-you-are-in-offline-mode-because-you-have-no-active-internet-connection-p2/28723/3?u=avalanche_knivspark

Sorry for the inconvenience and thank you for your patience :pray:

1 Like

Hello again @AngryGamer :wave:

Pretty sure that what you are experiencing is different from this particular issue. Although somewhat similar, THIS link here is the thread for the issue you are having so please direct any comments regarding that issue there please: Stuck in offline mode - Trying to access multiplayer results in "You are in offline mode because you have no active internet connection."

however, I understand that topic has been locked for a while but we’ve decided to open it again and use it as the main thread for the “Stuck In Offline Mode” issue, while this topic here is for the “Failure to Join - Host Is No Longer Present - Unable to play MP with friend” issue.

1 Like

Hello @MrRoboto, @bongo, @SoHLunchBox and others who might be experiencing this issue :wave:

This issue has now been observed internally on more than one occasion so we have seen it occur ourselves, although we only get it occasionally and it eventually stops occurring so it’s not 100% the experience you describe. However, the fact that we can reproduce this to some extent should hopefully make it easier for us to identify the issue.

That said, I can sadly not give an estimate on when this particular issue will be fixed at this time. We thank you for your patience and understand that you have waited a long time for this to be fixed, your frustration is understandable, but know that even though it has yet to be fixed we do intend to fix this. As I mentioned in this reply on another forum topic, there are many reasons as to why sometimes an issue isn’t fixed quite as soon as we’d want them to. Thank you for your understanding.

Now, when we have gotten this error message internally we have a workaround that have helped us get around it and I thought I’d share them in case it turns out they work for you too. This is just something to try out and hopefully it’ll help at least work around the issue, but keep in mind that there’s no guarantee it’ll work since the issue may have behaved somewhat differently for us.

Please try this potential workaround:

Note: You MIGHT be able to skip step 5.

  1. Make sure there is a joinable (open) session available hosted by a befriended user
  2. Try to join via in-game friends list or invite
  3. Get the error message “Failed To Connect - The host you attempted to connect with is no longer present”
  4. Go into a single player session via “continue”
  5. While in the single player session try to access the multiplayer menu (Sometimes you can get “invalid session” error message for a while shortly after starting a session, if you get that message repeatedly give it some time and keep trying now and then, and give it at least 1 minute or so)
  6. Go back to the main menu
  7. Try to join your friends session via in-game friends list or invite
  8. IF the issue keeps occurring try reversing the roles and having the other player be host/client

Let me know if that helps/ does not help and If it doesn’t work please try to describe step by step what happens when you try it.

Again, thank you for your patience and sorry for the inconvenience :pray: IF there’s anything new to report I’ll make sure to come here and share it with you guys!

/Best regards, Knivspark

1 Like

@SR_knivspark

Will do, thanks for keeping us updated!

1 Like

Hello,

We tried the steps provided, exactly as mentioned, step-by step. The same error continued to occur at the end of each attempt and even after retrying the steps a second time while on NAT 3. We were able to access all the menus on our own, single player games and no issues happened except when we tried to join each other’s games. We tried the above steps also with reversed roles to the same result. Tonight, however, we were able to play together due to me being at my home for the holidays. However, we could only play while having multiplayer set to open. Having the multiplayer set to “friends only” would give the same error message we experienced on NAT 3.

1 Like

Hey @MrRoboto :wave:

That’s interesting :thinking: I’ll make an attempt at summarizing below (please correct me if I’m wrong);

  • The potential workaround I suggested in my earlier comment did not work on the NAT 3 college campus network
  • You were able to play together with your friend while on a different network (not NAT 3 - The college campus network), but ONLY when you had the “who can join”-setting set to OPEN, otherwise you’d get the same error message as before (Failure To Join - Host Is No Longer Present)
  • Question: Did you try to have the “who can join”-setting set to OPEN while on your other network (NAT 3 - The college campus network)?

This is new information (testing another network + who can join setting) and hopefully it can steer us in the right direction for figuring this out. Also, I’ll make a note on the ticket to take a closer look at the “friends only” (who can join) setting as that sounds quite suspicious.

Thanks for the update! We appreciate it! :pray:

2 Likes