Stuck in offline mode - Trying to access multiplayer results in "You are in offline mode because you have no active internet connection."

acknowledged

#1

Pretty certain I have an internet connection… I did download the game. PC btw. Steam.

It ran fine for the first 4 hours, I played SP but it said I was set to invite only so I assume it connected.

I’ve been told it has been an issue since release that devs just… haven’t bothered to fix.
Not sure if I believe the company is comiting fraud so here is my 3rd attempt to contact the devs.

Anyone have a fix?
Anyone know what is causing it?
Being a bug for a year is sort of messed up.


You are in offline mode. But I have internet connection
#2

Sooo… nothing? Bit of a bad image. Is the game abandoned or something?


#3

The game is not abandoned but you can’t expect with certainty that devs have the time to read forums and react to it. If you have a bug to report go through the right channel by first reading this post. I am just a player who comes to this forum to read about the game, fun stuff preferably.


#4

@Gysbert puts it accurately. Yours is the first time I’ve heard having this issue, I’ve played the game since launch both single and multiplayer and I’ve never experienced it. A full bug report with all the details included would help.

For that matter, don’t be so quick to jump to conclusions like the game being abandoned or the company committing fraud just because you have an issue that’s not immediately noticed. That doesn’t help anyone and only serves to get this topic archived sooner.


#5

Hey @TheRealTenman :wave:

+1 on what @Xezr said. Would be great with a more detailed and descriptive bug report so we can get a better understanding of the issue that your are describing. Please try to describe the issue in as much detail as possible (If you can provide screenshots or video that would be helpful too).

  • What exactly is the issue you are experiencing?
  • What happens when the issue occurs?
  • How often does it occur?
  • Can it reproduced following a set of steps?
  • Do you know if there are others having the same issue as you? You mention that you were told that this has been an issue since release, since I’m not entirely sure what the issue is at this time it would be great if you have links to other reports or mentions of this!

Thank you for your time and thanks for reporting!

EDIT: I edited the title of this topic to hopefully make it easier for others to find this via search terms in case there are other having the same issue who are looking for info.


#6

Platform:
PC, steam.

Description:
When clicking multiplayer it says "You are in offline mode because you have no active internet connection. Certain features, such as multiplayer, will be disabled.

Steps To Reproduce:
Start game, click multiplayer.

Images / Videos:

Host or Client:
N/A

Players in your game:
N/A

Specifications:
Windows 10 64bit
Wi-fi extender plugged into PC. Shared Wi-fi.

Other reports
A few others on steam. Every thread had someone saying it was something since release.

Occurence
Everytime other than my first start up. It said it set itself to invite only so I assumed it worked then but I only played Singleplayer for that 4hour session. I was waiting for my friend.

Things I’ve tried to fix
Restarting, game and PC.
Resetting router.
Checking integrity of cache.
Whitelisting through firewall.
Disabling firewall and security.
Running as admin.
Mixes of the above at the same time.

As for the snark im getting and that is getting supported by Avalanche_Knivspark;
I am NEW to this game. I was TOLD it hadn’t been fixed by SEVERAL people who also had the issue. I said I was NOT sure about the whole fraud thing, so I tried contacting. There was no official response on steam, the platform I use, for several days. All I got was several people saying that it never got fixed and one being an internet person and saying it wasn’t a bug…

2 week days is plenty of time in my opinion to earn a bump asking if the community is even active. Turns out it is, you just need to poke them 2 of 3 posts threaten censorship.

Good to know that the devs “archive” posts that are deemed to have jumped conclusions. Great community here I see. You are really helping the whole situation with threats of censure Xezr. It also helps that you personally haven’t had this bug. It definitely adds a lot of useful information. That is sarcasm in case you don’t know.
And for the record, asking questions is not assumptions. It is literally the opposite in fact.

But cheers. The response from Gysbert genuinely helps. Especially the link. Hopefully everyone calms down.

Hopefully Knivspark can help solve this. The SP rocks and I would love getting MP to work.


#7

I’m not a developer, just a moderator. I do this is in my spare time. And when I see that someone violates the Code of Conduct, I remind them why they shouldn’t do that. Namely, this section;

We don’t allow being overly and repeatedly negative which knowingly lead to overly strong negative and emotional responses for mere shock value. We will remove posts that are derogatory, sarcastic or showcasing a condescending/demeaning attitude towards other users or the developers.

When you post on the official forums you will follow these guidelines just like everyone else. That’s all.


#8

Hello again @TheRealTenman :wave:

Thanks for providing us with more detailed information. I must admit that I had a hard time grasping just exactly what issue you were describing in your initial report, but now it’s a lot clearer so thanks for taking the time to do that.

So I did some searching and found a few old mentions of this on Steam, one of which mentions that they had this issue (“stuck in offline mode”) and they got around it by disabling their VPN (See link below).

Any chance that you have a VPN enabled that could be interfering with the game?


#9

I’ve had the game for a few days and have consistently had the message “You are in offline mode because you have no internet connection.”

I am connected to the internet and have no issues for multiplayer for steam and other games like call of the wild for example.

Ive seen a couple of others post this problem elsewhere on the internet but none with a response.

Any ideas?

Thanks!
704270_screenshots_20200409145900_1|690x320


#10

This post was flagged by the community and is temporarily hidden.


#11

That’s not really a solution


#12

Same issue topics merged.

Also, anyone else who has issues getting out of the Offline Mode, despite having working internet connection, are welcome to post their issue here.

//Mod


#13

Now, as for the unfortunate tone of the discussion going on here, please try to keep calm, and even if you are frustrated or angry, try your best to be polite and respectful when interacting with others. This goes for everyone in this forum.

If you want to know more about this, please see our Code Of Conduct that @Xezr shared.

I hope you understand that we are here to help and that we do our best to do so, and I really hope we can help you get this issue sorted.

We are a small team of less than 30 people working on this game and we try to keep track of bugs that are mentioned online, and we actively take the time whenever we can to look around and respond when time allows, but being a small team it’s not an easy feat for us to respond and handle everything that is posted online on reddit, steam, twitter, facebook, youtube, other sites AND this forum. If you would have posted here in our official forum from the start I imagine response time would have been faster, but we can’t guarantee that we’ll always be able to respond as quickly as you’d like, but know that we are doing our best.

PS. Thanks again for providing the additional information and screenshot @TheRealTenman :pray: that helps us a lot!


#14

I do not have a VPN unfortunately so I cannot test that. I have reset the router though. No luck unfortunately. I assume it has something to do with the fact I am on a community Wi-Fi, but we all know what assuming does.

Is there some form of important difference between Private and Public Wi-Fi that could be the cause of a security error on my end or an oversight of code trying to select the other?
I remember reading something about 2 people not being able to play from the same router at the same time but that may be completely unrelated and not helping at all…


#15

Noted, thanks for the swift reply @TheRealTenman!

I see, then I must admit I’m getting somewhat suspicious to how our game handles different kinds of networks and network setups, with extra suspicion towards public “community” networks. I will raise this with our network coder and see what they think about this.

Also, I have recently discussed a multiplayer/networking issue with another user who’s on a college campus who’s unable to connect to and play with their friend. Unable to play multiplayer with friend - "Failure To Join - Host Is No Longer Present" error message shown

If possible, it would be really interesting to know if this issue does not occur IF you would be try and play on a different network. I understand this might not be an easy thing to do depending on your hardware, access to other networks etc, but it sure would sure be interesting for our investigation to know what results you would get on another network.


#16

I was thinking of getting a little USB modem for myself so I might just do that. Money though : C

No promises on that but if I do find a decent plan and I get the other internet connection I will pass on if it fixes it. Cheers for trying.


#17

Any news on the hunt for the bug?


#18

Hey @TheRealTenman :wave:

Nothing new to report at this time, information is still being gathered.

Have you gotten the chance to try and play on a different network?


#19

Unfortunately no I haven’t gotten another connection. I’m broke as hell.


#20

LOL i hate copy/paste help as i read this i just facepalm
“So I did some searching and found a few old mentions of this on Steam”
Why should OLD mentions help on a newer game build?
The game was runnig perfect before last patch!
So the error YOU ARE OFFLINE is since the latest Patch!

It just happens one day you can play the other the game is broken.
…so are there any REAL Helpfull tips??
Like does anybody know is it on all Windows built 1709,1909 i have more problems with 2004 built than 1909 is the SteamWebhelper.exe bloatware needed?
As i use command -nobrowser to stop Webhelper starting up like 11 times
Could some Developer take a look into there game what they have changed to force this OFFLINE BUG please!!
Thanks in advance
DaAngryGamer