Stuck in offline mode - Trying to access multiplayer results in "You are in offline mode because you have no active internet connection."

As i allready asked is there a fix for:
You are in offline mode?

Its NOT my end here as i can play evrything else like:
Insurgency Sandstorm, Battlefield,Star Wars Sq. ,RaceRooom,War Thunder,World War 3 all my games.
I searched the internet this Forum also setup Windows new…nothing works.
If i join a friend who plays it works fine.
But find a lobby or host to join impossibel.


Don´t know if needed System build

  • CPU: Intel Core i9-9900K @5 GHz | Cooling Corsair H115i Pro
  • Motherboard: Asus ROG STRIX Z390-F GAMING Z390
  • Hard Drive: Samsung 970 Evo M.2 SSD 500GB + 1 TB Samsung 850 EVO
  • RAM: 32GB DDR4 3200 Ripjaws
  • GPU: Zotac GTX 1070 AMP!
  • Screen: Acer Predator XB272 1920x1080@240Hz +G-Sync
  • Headset: Beyerdynamic 300MMX
  • Keyboard: Tte Sport Challenger Edge
  • Mouse: Logitech G502 Protheus Core @400-450DPI

In the latest patch notes it mentions you’ve fixed the “no internet connection” bug.

It is still there for me. Is this the same bug from

I would ask on the thread that I started/ got merged but Xezr locked it so I can’t ask there.

From the earlier topic, the latest advice for your issue was for you to try playing on different network. Have you done that?

Also, @SR_knivspark, care to join us here?

Hi @TheRealTenman :wave:

Sad to hear that you are still having this issue.

However, I am not seeing anything in the November patch notes about a fix for this? And looking in our internal bug tracking database the ticket for this issue is still open/in progress.

Sadly I do not have anything new to report on this issue at this time. We intend to investigate this further, however our network coder has been swamped lately and this particular ticket (although high priority) has yet to be looked by code as other issues occurring for the majority/many users has taken priority.

That does not mean we don’t consider this issue important, it’s just a matter of us having very limited resources and having to prioritize accordingly.

:point_up: IF you possibly could try this it would be very interesting for us to know what result you get (e.g. bring your console/PC to a friends place and try the internet connection there, or alternatively just trying other available internet connections around the area where you reside, wired or wireless)

I’ll add this new forum topic to the ticket so the coder can follow the discussion here when they find the time to look at it. If there’s any updates on this issue I’ll come back here and share it.

Thank you for your patience, and thanks for reporting! :pray:

Merged topics, and unlocked. Let’s keep it in one thread.


1 Like

Hello @TheRealTenman, @AngryGamer and others who might be affected by this issue :wave:

TLDR; At this time I’m afriad I have nothing new to report on this particular issue.

I understand your frustration that this hasn’t been sorted out yet, it’s been a long time since you first reported this and it’s unfortunate that you still aren’t able to play multiplayer.

As I’m sure I’ve mentioned before, we are tracking this issue with a high priority ticket and know that we do intend to investigate and fix this. However, also try to understand that there are many reasons and factors as to why an issue isn’t fixed immediately or as soon as you’d want. Below I’ll list some things that might shed some light as to why this particular issue hasn’t been fixed yet.

  • Although Avalanche is a reasonably large studio there are many teams of various sizes in the studio working with different projects and budgets, and the team working specifically with GenZ is small and therefore our resources are very limited
  • Even if we’d like to fix all issues that are reported by our community we simply and realistically can not. With our limited time and resources we must choose and prioritize carefully and sometimes that means that even tissues that have a high priority to be fixed have to be pushed along until the next release (patch), or even the release after that.
  • It might seem unfair but often serious issues that are experienced by the majority/many players tend to take priority over issues that are experienced by a fewer number of players (But as mentioned earlier, we DO intend to fix this)
  • Lastly, this issue is a tricky one and quite challenging to deal with as there are fairly few reports of it and thus far we don’t know how to reproduce it ourselves and we are not sure why it occurs (but with more information, reports and investigation we can hopefully figure this out)

Thank you for your patience (you have waited a looong time), and sorry for the inconvenience :pray:

/best regards, Knivspark

1 Like

IF anyone experiencing this issue (or not) has information that they think could be relevant for understanding this issue better, please share it in this thread. We’d be grateful for any kind of information or clues that could push us in the right direction in our investigation.

Note: The information from earlier reports and comments have been noted down on our ticket for tracking this issue and we appreciate the information we have gotten thus far, but maybe there is something more to this that we haven’t considered yet, and that is why we want to open up for more info/reports to be shared and added to our knowledge base regarding this.

Cheers! :pray:

PS. Also, as a hopefully unnecessary preemptive measure, I would like to remind everyone to keep a civil tone, even if you are upset or angry. We understand your frustration, but anger and hostility doesn’t help anyone in dealing with this issue. There is a code of conduct and we expect everyone in the forum to follow it. Thank you!

EDIT: FYI we are also tracking this issue which has some similarities to this one, but is somewhat different; Unable to play multiplayer with friend - "Failure To Join - Host Is No Longer Present" error message shown

All good. I was refering to this section of the patch.
" General

  • [Community Report] Fixed an issue where it was quite common to get a “Failed to Connect” message when attempting to play multiplayer"

I guess I interpreted it wrong, It could mean a lot of things, I guess it means what it says exactly. All good, Good luck with it. I’ve managed a bit better of a budget lately, I should be able to try a different connection sometime soon.

Have a good one.

1 Like

Hi, I wish someone could help me, I’ve been trying to play with my friends for months and I just can’t the game keeps saying that I don’t have an internet conection when It is obvious that I have, I’ve tried a clean reinstall, clean cache, everything, I literally have tried everything and still doesn’t work, please if someone can help me I would be so gratefull

Same issue topics merged.


1 Like

Hey I’m having the same issue.

Interestingly enough my friend can invite me to his game via steam, while all I can do is invite to watch.
I’ve tried everything aforementioned, other than switching networks as it’s a desktop without wifi…

I’m wondering if the bug has to do with steam at all, as I started playing the game while I was offline.
Shot in the dark, but I don’t know if there could be some sort of first run check that may be the cause.

Other than this one “offline only” bug making me unable to host, the web coding was great!
We live on opposite sides of North America and the game felt exactly like singleplayer offline.

Hope this helps the devs, if only a little…

Turns out Windows was sending false information to the game by not detecting my internet/not properly setting up an IP for the computer, I “reset” Windows and it all works, no “offline” prompt.
Testing if I can host soon.

EDIT: Everything works great!

Reset meaning I went into system recovery and clicked “reset PC”.


Hello @NoSkillNoble :wave:

That’s great news! Good job finding that out :+1: hopefully this can help others experiencing this issue as well.

Also, before people try this, maybe you could explain in a little more detail what the “reset PC” action does to your PC? E.g. will it involve any kind of data loss? Reading the support page (linked below) it seems windows will be reinstalled, and all your files, settings, and software will be deleted, meaning you’ll have to backup your files somewhere and install all your software/games/etc again.

From the windows support site: (linked below)

This is what you are suggesting right?

Does this (the workaround posted by @NoSkillNoble above) work for you guys as well @TheRealTenman, @AngryGamer ?

EDIT: I totally get if you aren’t up for applying this workaround due to how potentially disruptive it is.

Like @SR_knivspark suggests, I can confirm that committing to a System Recovery WILL wipe all your files. Don’t use that option unless you’re, well… Out of options. Backup your files.


Any idea what specific file it was? Or program?

I really… REALLY don’t want to wipe my PC…

1 Like

Hint for fix, or how i fixed it …
Reading through the above 1 thing gave me a hint:

… turns out Windows was sending false information to the game by not detecting my internet/not properly

checkig my network setup, sure enough windows was reporting that i did not have a network ( Setings -> Network & Internet) which was patently untrue!.
after much back and forth, repairing, shutdowns and restarts, windows network status finally reported that “You’re connected to the Internet” and GenZ imidiatly worked.

So, conclusion: GenZ might blindly believes what windows network status thinks is the status of the net.

So that might seem to be the root cause…

I made a forum account just to reply to this, for if you come here looking for an answer. I scoured a dozen other sites tracking this issue down, and found a solution!

The issue is tied to a faulty windows update that causes the system to be unable to test its own connection. This happened in 2019, and was since fixed. BUT, if you had the bug, your windows update will not trigger as it thinks it is offline.
Generation Zero seems to rely on Windows connectivity reporting, unlike many other games that ignore that and just test connections themselves.

Solution to fix this on Windows 10:
Go to the Microsoft Windows 10 download site and use their ‘Upgrade’ link, to force a download of the latest Windows feature update. This will not generally erase anything, it forces a feature update around the updater software. It’ll take a while.

After this, the computer should be able to check its own internet connection again and therefore update… and Generation Zero will once again recognize you are online!

Hi there everyone. I’m having the same problem as some of you by being stuck in offline mode. Me and a friend used to play together but I can’t access multiplayer anymore. He is able to and we on the same network at my place of residence.