Unknown error when joining multiplayer

All good Mate :slight_smile:
Ok tried several times getting right out of the Game and Steam then re tried from Main Menu Multiplayer section and Joined friends session :slight_smile:
so Works some times but if it doesnt get right out of steam then re log and in to game then works

1 Like

It could be Steam issue as well, especially when you’ve hidden your “in-game” status.

To change that:

  1. Go to your Steam profile
  2. Click “Edit Profile”
  3. Select “Privacy Settings”
  4. Look for “Game Details” section
  5. Set Game Details either “Friends Only” or “Public”

If you have Game Details set as “Private” then no-one in your friends list can see you in the game and can’t invite you to join their game.

there’s also another error that has popped up more frequently after the update. Its something like “An error occured or the server is full” and appears when accepting invites.
Its not as common as “Unknown error” tho, but i havent seen it this often before the update and therefore seems related.

OK So I noticed what could be the error, From what I can tell if your on NAT2 is works fine, sometimes it might error out but a good 13 tries only once it failed and that was mostly me being dumb with the cable thats loose.

However, when on NAT3, this error comes up 99% of the time, unknown error, one one time i got to join out of god knows how many tries, but it lasted maybe like 5 mins before my partner started running in place and his actions did not affect my world anymore, even though it seemed like we were still connected.

My current theory is after the update they switch from server based hosting for MP (as in each client connects to a server and that server relays the actions and updates to the client) which is why it worked fine on NAT2/3 without issues but after the update I believe the implemented P2P (peer to peer, this means theirs no server involved, as in each player is connected to each other player directly) this works fine on NAT2 but is almost impossible on NAT3 due to ports being an issue, and P2P requires the use of ports to work properly.

my2cents

I think it’s always been peer to peer and if it’s a port problem is there a way to make an adjustment that’s not too complicated? Id really like to know because me and my crew always have this problem and it’s usually me that gets kicked from the group but I don’t realize it untill one of them tells me. The world continues to go on for me but I can’t open doors or loot bots etc. I have to leave the game on my own and go back in on an invite so there is no crash report generated . This only ever happens when I’m a client. Devs…are you wathching? I’ve posted this countless times on other people’s posts over the entire life of the game so far , we know you guys are a small team and have a lot going on but when you get the chance could you take a peak at this?

Pc
Cpu i7 8700k
Ram 64 gigs
Os drive 2TB
Secondary drive 1tb
Gpu 1080 ti

Thanks.

I persuaded a friend to buy the game when the Steam sale started. We’d previously played it back in April when the game was on a free week and I got a few friends to check the game out. At that time we had no problems connecting together for a private coop game.

I’ve not yet purchased the latest DLC, but he bought the Resistance bundle. Now we are unable to play cooperatively. We’ve tried joining each others game, and I even suggested he switches off the DLC content via the steam client (which you can do by going into your Steam library and going to the manage my DLC button, where you can then de-select any DLC you have installed. Even when he did this, we still couldn’t connect.

I believe that the recent release and update have also included new content in the main game (I’ve not read the latest patch notes yet) for example I noticed Tungsten can now be picked up and used via the crafting tables.

I do hope this unknown error can be fixed ASAP. We were really looking forwards to jumping into the world together last night and were very disappointed when we were unable to do so despite trying for almost an hour.

When I invite a friend to play there is always an error message even when he invites me: unknown error … the problem has only existed since the last update Sorry for my English it is Translate from German

Topics merged.

//Mod

I can’t play multiplayer in mode ONLY INVITE

after 150 hours of play, me and all my family got the same error: UNKNOW ERROR

Topics merged, again. Search, people.

//Mod

I made a post about disconnects on the bug report section just asking if there was a fix / going to be one, devs deleted it within 10 minutes. Good luck.

I removed it, because you had already posted the exact same thing in this thread. One post is enough.

Oh cool, didn’t think anyone would read the end. Glad its “acknowledged”

So far i have gotten around this unknow error with friends.
PC 1 host launch game. PC 2 client tries to join game = unknow error
After this PC 1 host invites to game lobby, PC 2 hast to be loaded into game. And then you get into the game.

This has worked so far, this is not guaranteed workaround.

Still no fix? It’s been almost a month since the last post.