Unknown error when joining multiplayer

acknowledged

#1

Hi,

we purchased the FNIX Raising DLC, everything is downloaded and installed on both client and host, but when we try to join MP session after being invited, it shows APEX logo followed by Unknown error message - after clicking OK I end in Main menu.

Tested couple of times and even swapped the client and host roles.

Platform is PC, the game incl. MP worked yesterday.


Unknow error MESSAGE
I can't start multiplayer with a friend
#2

We see the same tonight.

My two friends, who have not yet installed the DLC can join each other, but I cant join them. I have the DLC downloaded and installed.


#3

Same issue for us…
My wife and I cannot play together after FNIX Rising patch update - VERY SAD!


#4

Ive been having the same issue, both on my own computer as well as my sons (playing together).

I might be wrong here, but i feel that the error doesnt occur as often if you click the invite then QUICKLY alt-tab back to the game.
At least, it seems to work allright for our setup here.


#5

Hello everyone :wave: @liggisten @ContosoGamer @neoslc @xMstSpider

We have a high priority ticket for this issue in our internal bug database and if you could provide us with some additional information it would go a long way to help us identify and deal with the issue.

Is this issue occurring with all the multiplayer options?

  • Find Game
  • Join via invite
  • Joining via in-game friends list
  • Joining via steam friends list

Is this issue only occurring if you have the “FNIX rising” DLC installed? Or does it occur regardless if the DLC is installed or not?

Sorry for the inconvenience and thanks for reporting! :pray:


#6

Hello @Avalanche_knivspark :slight_smile:

So we tested a bit more yesterday:

  • PC1 starts the game, invites PC2 --> Unknown error
  • PC2 starts the game, invites PC1 --> Unknown error
  • PC1 and PC2 start the game, PC1 invites PC2 --> it works

As I wrote yesterday, we played on Monday and it worked normally, after installing FNIX Raising DLC, we got the Unknown error first time we started the game.

To answer your questions:

  1. Find Game: OK
  2. Join via invite: Unknown error
  3. Joining via in-game friends list: OK
  4. Joining via steam friends list: Unknown error (I guess this is same as 2, since GZ uses Steam friends list?)

Thanks


#7

Invite from PC1 in-game to PC2 did not work. PC1 picked PC2 from Steam friend list.

Select PC2 under Multiplayer in-game dont work first, but then it does…


#8

@Avalanche_knivspark: Ive been experiencing this issue again and again, and it seems especially hard for my son to join with a invite. We only play with invites so i cant say how it works when joining a random server and ive never seen a option for joining a friend without a invite.

But it really feels like the delay between clicking “accept” and switching back to the game affects this issue.
I usually have my left hand resting on the alt+tab-keys while i click accept on the invite and it usually works for me on the first or second attempt, but my son is not as fast and can sometimes require 10+ invites before he can join, unless i help him accept.

To be more specific, it is usually less than 2 seconds from clicking accept to entering the game for me, seemingly before the game loads that square dialog window “joining game”.
So it seems that when i switch back to the game late, the dialog window is already there with the message " unknown error".


#9

Same for my Wife and I
Was working prior to FNIX rising
always easy to join from my game or Hers.
Now Get same error as OP
Can Find a Game but never hers.
I Even fully uninstalled the Game and created a new Char with same Error.


#10

Hey @liggisten

Have you tried joining via the “in-game friends option” or joining via each others steam profiles? To do that you’ll need to (at least temporarily) set the “who can join” setting in the multiplayer menu (after you have hosted).

  • Player A & B: Have befriended steam profiles
  • Player A: Host a session
  • Player A: Open the multiplayer menu and set the “who can join” setting to “anyone”
  • Player B: From the main menu go into the multiplayer menu
  • Player B: Look at the bottom of the screen and wait for a “friends” tooltip option to appear, when it appears press the shown key
  • Player B: Click player A’s session from the list to attempt to join it

(OR, instead of using the “in-game friends menu” you can try to join their game via their steam profile)

Note: Sometimes the “Steam friends menu” is disconnected when you start Steam and you’ll have to manually reconnect it to be able to see befriended user’s sessions and join them via in-game friends menu, Steam, etc.


#11

Thanks @Avalanche_knivspark for pointing out this method! :slight_smile:

I got a friend to help me for this TS-step and here’s the result:

When my friend has activated “Anyone” in “who can join”, i get a friend option in the multiplayer menu, and i can join without any issues.
My friend did have to quit to menu and restart his game world for this friend option to appear.

But there was no option to join from the steam friends list, not “in-game” (with shift-tab) nor in Steam (alt-tab).

Since we’re on the topic, how about adding a 3rd option to the “who can join” menu, “Friends only”? :slight_smile:


#12

Sorry Cant see In-Game Friends Option
But Have tried Joining from Steam Friends Playing Still get the Same error
Happy to go into Discord and do Go Live Screen share if it will help


#13

Sometimes it can take a while before the “friends” option pops up, and if it’s still not showing and you know that you have a friend who has hosted a session have them quit to main and start a new session again, OR try going in and out of the multiplayer menu to see if it updates and the “friends” option appears.

That said, if you get the unknown error when joining via steam friends it is likely you’ll get the same result here…


#14

waited 20 mins still no Friends indicator down the bottom :frowning:


#15

For me at least, that “join friend”-option didnt show up unless my friend was hosting a " who can join=everyone"-session.


#16

Oh, yeah shouldn’t have to wait more than a few seconds :grimacing: sorry for not specifying expected time frame.

yeah what @liggisten said above!

Could you please double check that…

  • The “steam friends menu” is connected (right-click the steam icon and click “friends” to open it)
  • Your friend has their hosted session set to “anyone can join”

#17

Thanks @liggisten tried on Both PC’s with Host as anyone made no difference.
Missus Pissed we cant kill shit together :slight_smile:


#18

@Aussieastro Try to exit the session after making sure “anyone” is set in the multiplayer menu(dont forget to apply!); quit to menu and re-enter the game world. That worked for me.


#19

Yes Steam friend Open in Both computers.
Both Game setting set as Anyone can join
OK SOoooo
you needed to say Multiplayer from Main Menu Not In Game :slight_smile:
and Yes Friends come up from Main Menu > Multiplayer >
and Can Join Wifes Game :slight_smile:
But she cannot invite with out Error so this is at least one way around :slight_smile:

BUGGER !!! got out of her game to type this now get Error Message :frowning:


#20

Pretty sure I mentioned that but it’s ok :smile: it was a bit of wall of text going on there so no worries!

So it worked for you joining via the in-game friends menu, but now you get the error message on trying it again? :grimacing: Please try a few times with the join via in-game friends menu, also try joining via the steam friends menu interface, clicking “join game” on their profile (which should function about the same). Are you completely unable to join each other or does it work sometimes?

And like @liggisten mentioned above, don’t forget to click “Apply” after changing the “Who Can Join” setting.

Thank you for your patience in dealing with this issue @Aussieastro :pray: much appreciated!