Unorthodox Skiing mission

acknowledged

#1

Unorthodox Skiing is a buggy mission. It doesn’t register as a failed mission because I cross the finish line down in the slope with the bike. I quit the game and came back in the Safehouse. The countdown started with 40 seconds when I’m in the safehouse? What the heck?


#2

Does anyone have an issue with this side mission, Unorthodox Skiing?


#3

I didn’t have any issue with the mission, tho I completed the mission with a second to spare, but it may be like (ex. “00.39.725”). The mission is repeatable if you get the mission failed and all you have to do is go back to the shed where the mission starts. I may suggest building up some speed with the bike before starting the mission and follow the ski path to the end and you should be able to complete it by a second or 2.


#4

I have tried that, it didn’t show as countdown after I failed the mission. I even went cross under a finish line where the marker was. It didn’t register as failed mission or anything. So I quit the game, load the game up.

You know what happened next? As I was in the safehouse after the game load up, it has a timer clock down for 40 seconds. I knew that wasn’t normal. So I tried to race to get a bike off of a bike station from safehouse and race through the little shed. Time ran out but the mission banner on the top left is still there. It’s very hard to explain. I wish this forum has a function of a video I could record it to show it to you.

I tried to go back to the bike shed where you would start the mission again. It didn’t register timer countdown at all. Only if I quit and load the game again, it will shows a timer countdown. I think it’s buggy.


#5

I’m not sure if this will help or not, but which platform are you currently playing on?

When I was doing the mission it was working fine on Xbox one at least for me and I don’t know if another Xbox one player will get this glitch/bug or not. I’m not entirely sure if this idea works or not, but if you get the timer again after logging out & logging back in just wait till the timer goes away and attempt the mission again.


#6

Xbox one. Believe me I’ve tried to log out and log in. This is what I get after I logged in. The timer ran out of course after I hurried to get out of the safe house and tried to finish the mission but it is impossible. I ran up to get a bike again and tried again from the shed, the timer never shown up or even recognize that I failed the mission either.

I couldn’t get the achievement unlocked after I completed the first dlc mission, Not Alone, either. This DLC is a mess.


#7

I see and unfortunately I don’t know a workaround for solo play as the DLC is working just fine with me. Haven’t tested playing in co-op yet, but I’m not risking the DLC glitching out on me. As the only thing that has happen would be crashes while exploring/looting.


#8

Hi @MotorexGTR32 :wave:

We’ll investigate the issue.

Thanks for reporting, and sorry for the inconvenience!


#9

Here’s a video I recorded

https://www.trueachievements.com/gameclip.aspx?clipid=139593812


#10

Not seeing a video when I visit that link. Maybe it’s not public or something like that?


#11

Oh, which means you have to be a member of trueachievements.com

I’m trying to find a way to post it on YouTube but I can’t figure it out. I’ll let you know.


#12

I usually share to Twitter, then post a link. Or you can upload it on Xbox live, then link to it from; https://xboxclips.com/


#13

Oh man, @OBiW4NSHiNOBi you are awesome!

https://xboxclips.com/MotorexGTR32/38d61467-e88f-4819-b2c5-8c467cbc510a/embed


#14

Can see it now, cheers!


#15

it is a bit annoying
pc win10-64 nvidia 1060 i5-8600k 16 gigs ram