Various D3D Errors

I’m getting graphics related crashes after the April hotfix (I have been spared from crashed before)
So far I’ve seen
D3D Error 8 Creating Backbuffer Failed
D3D Error 23 texture 2D Creation Failed
D3D Error 11 Vertexbuffer creation failed

They all happen relatively quickly after I spawn (30 s -> 1 min). Normally result in back screen (with sound) and sometimes I am allowed to generate a bug report I can submit. I’ve still been able to play (yesterday I could play after having issues for some time, then it just worked)

Noticable maybe Steam consistently crashes at the same time, I have have to restart Steam again.


Steps To Reproduce:
Start up game, load world and start playing
Images / Videos:
See attached
Host or Client:
Players in your game:
Windows 10 Home 64-bit
i5-4690K CPU @ 3.50GHz
8GB ram
NVIDIA GeForce GTX 970

first try to update the drivers for your video card, as this is related to that. The card itself should be fine though as I have the same one and it works well.

If you still have issues I would try to run the game in borderless windowed mode and see if you get a different result.

Thanks for the tip. I tried various settings without success before posting the problem. Today I had to take the monitor back for service, so it may have been a hardware related problem. Running another monitor now and not getting these problems, so fingers crossed.

Steps To Reproduce:
Occurs randomly, middle in the forest, after a fight, inside buildings.
Host or Client:
Client and solo
Players in your game:
1 and solo play
Windows 10 Home 64-bit
i7-5820K CPU @3.30 GHz
16GB ram
NVIDIA GeForce GTX 1080
Monitor: ASUS 2560 x 1440 144Hz G-sync

Bought the game 3 days ago on steam with my partner and we have been playing togheter since then, but every so often my game crashes and this error message displays:
Error, D3D Device lost
Device removed, reason: DXGI_ERROR_DEVICE_HUNG:
Graphics device stopped resopnding. There might be an infinite loop in a GPU program.

I’ve tried the following:
Verify integrity of game files: no go
Run as admin: no go
disable Fullscreen Optimizations: no go
DSR off: no go
Nvidia control panel Manage 3D settings:
Program settings
Open GL rendering GPU, Geforce GTX 1080: no go
Power manager mode: maximal performance: no go
all of these trial and errors I found on various sites that was similar to my problems but no joy.
I’ve doubble checked that Nvidia drivers was up to date and DirectX and I have the last drivers of both, tried a clean installation on both drivers to be sure I had the last drivers and tried to run the game but no joy.

I can play for 5-10 min before it crash and sometimes 30min to 1.5 hours so the occurance is randomly.

I hope I can get som help because I love the consept of the game and the mechanics, and I will not give up hope on the game just because some bugs and crashes.

Are you overclocking your GPU?

I had similar problems and setting standard clocks solved it.

most times I run EVEGA precition X, and had a few tries with an without it all other games I run GPU clock offset +100 MHz and +200 MHz, just tried to down clock GPU clock offset 0 MHz and MEM clock -200 MHz and got 45 min play before I had to go. Gonna try it again now to see if I can get +2 hrs playtime, at least I know then if it is a software issue or hardware issue :slight_smile:
Thanks for the reply :+1:

The game was running fine for months, today I had two crashes with the error message “D3D Device Error”.
Does anyone know what this means, why it suddenly happens and what to do about it ?

Has anything changed on your computer recently? Such as updating your graphics drivers?

Platform: PC

Description: Open the game and join my friend’s game through the steam client. I spawn at the first farm safehouse, while he is at the town safehouse (this is normal), but on the way to the town, I always crash, usually around 5ish minutes of playing. D3D Graphics error (view attached screenshot)
My graphics drivers are all up to date.

Steps To Reproduce: Launch game, join multiplayer session, play for around 5-10 minutes.

Images / Videos:image

Host or Client: Client

Players in your game: 2

Mobo: Z730 Aorus Gaming 5
CPU: Intel i5 8600k
GPU: EVGA 1070ti Superclocked
PSU: EVGA B3 650w
RAM: G.Skill TridentZ RGB Series 16 (2x8GB) 3000MHz

I updated my AMD Radeon drivers yesterday to their latest version and I now Generation Zero crashes immediately upon start up and gives me the following error window:

Fatal D3D Error
Please ensure your GPU meet the minimum requirements and
that you have the latest graphics device drivers installed.

Below is my system information:

OS: Windows 10 64-bit
GPU: AMD Radeon RX 5700XT
Driver Version: 20.4.2
RAM: 16 GB

A workaround at the moment is verifying the integrity of the game cache. I did this both yesterday AND today. No files had to reacquired to downloaded. I’m not sure what why this works, but seems to keep the game playable until I restart my computer. Then I have to verify the cache again. Here are my graphics settings:

Screen Resolution: 2560x1440
Display Mode: Borderless Window
VSync: Off
Dynamic Resolution: Off
Dynamic Resolution Target FPS: 60

Shadow Quality - Texture Resolution: Ultra
Volume Fog Quality: High
Anisotropic Filtering: 16
Motion Blur: Off
Screen Space Reflections: On
Global Illumination: On
Anti-Aliasing: FXAA + TAA
Chromatic Aberration: On

I thought about rolling back my drivers to the previous stable version, however, when I play the Division 2 the game or my drivers force HDR on in that game and I can’t turn it off which give the game a washed out look. Installing the new “optional” drivers I’m running now fixed that problem. Sadly, it created this new one possibly. Has anyone found a permanent fix for this or experienced this error?

Since that’s the thing which changed in your PC were GPU drivers and not the game itself, you’d need to look towards driver issues.

My advice, roll back GPU driver version to the one you had and wait until new version comes out, so that you can skip this buggy driver version.

Personally, i have never seen that kind of error, but i don’t use Radeon GPU either.

Run DDU on your drivers and then reinstall them fresh to rule out any conflicts with older driver files

Platform: pc

Description: I open game and this is what I am greated with

Steps To Reproduce: open game and thats it

Images / Videos:DSC_0226

**Host or Client:**both

Players in your game: 1

Specifications: GTX 1650 Intel i5 4460 quad core ram 8 GB storage 75 GB

Merged several topics where people have had D3D Errors.