Weapon at stenungsnas generator unobtainable

After doing FNIX mission for Stenungsnas Generator the generator stopped working and now the weapon on top of the wall is unobtainable. How about a way up on to the wall that does not rely on a destructible, non-respawning object. I now have no way to complete that area because I now have no way to get up on top of the wall.

I noticed this a few days ago, too.

There is maybe a way to get there, but you need four players that work together. You will need some practice, patience and good timing.

  1. You can jump on a crouching player.
  2. You need to jump up again when the other player below you stands up.
  3. The other two players do the same right next to you.
  4. The other upper player then needs to crouch, too so that you’re able to jump on him, too.
  5. Do the same as in step 1 and 2 but now with the other upper player.

Now you could be high enough to jump onto the wall to reach the weapon. Maybe.

P. S. I just did this at some other places with one additional player in the game to reach some balconies for example, but should work with more players as described, too.

Yeah…except for the fact that there’s only me and one of my friends playing this game…so, no.

I play single player and, if I can manage to jump and place a field radio up there, I can fast travel to it.


Tried it and couldn’t get a radio on top of the wall. Tried in a couple of different places. Can’t get a bike up onto the defunct generator to get a little more height, either.

Here’s the thing, if it requires me to use an exploit to do something legit, like finish a mission or a location, that’s called poor design.
You know how you eventually kick toxic people out of your life? Games are the same way. Persistent bugs, poor design, crashes, unobtainable objectives and missions or assignments that can’t be completed are aspects of a toxic game. Eventually I’m going to have to move on and stop spending money on it. Now I just started playing this game and I like it so I’m giving them a chance to fix this stuff, but I’m too old to waste much time.

I too am having this issue and cannot retrieve the weapon here. Be very useful if this was sorted with a more accessible method of getting to the weapon.

I made a video to show how to reach it, but 2 players and the tactical equipment dlc are necessary.

If your solo you could attempt to launch yourself using a rocket at low health which can ragdoll you but you may need a lot of adrenaline shots and rocket ammo. To be more specific I used the RLG-7
to get on the wall.

After a fresh start, the power generator still worked for me, which is installed in the middle. It is important that you have not yet completed the tasks of the DLC for the south coast before the cannon has blown up. If that’s already done, it’s probably only possible for two or with a new start.