Weapon Augmentation Bug

Platform- PC/Steam

Description- I unlocked the silver tier Scope Spotter augment with a 4 crown PVG 90 that had the bronze scope spotter and bronze EMP detonator on it. I went to a workbench, unlocked silver tier scope spotter and then tried to apply the silver Scope Spotter (yes, I had all relevant parts, I used a lot of my better stored weapons to come up with the weapon parts for augmenting). It took the resources and did the working animation including sound effects and… It not only did not give me the silver tier Scope Spotter, it removed the bronze Scope Spotter augment that was already on there. I had enough parts to try again, did and again it took the relevant parts, did the animation and sound effects but did not augment the weapon. I’m playing on the Samsung Smart Tv GeForce Now app, so I can’t provide a screenshot or vid clip, sorry.

Host or Client- Solo
Players in Game- 1 player
Specifications- Samsung Smart Tv GeForce Now App

I tried again thinking that if I went fresh back into the game it would help and the silver Scope Spotter didn’t work again, wasting all resources. However, this time I went to try the Bronze Scope Spotter and that worked. So it appears the bug may just be with the Silver tier Scope Spotter.